activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Segmentation fault while sending bytes messages
Date Wed, 29 Apr 2009 12:11:03 GMT
On Mon, 2009-04-27 at 09:44 -0700, manua wrote:
> Hi Tim,
> 
> In continuation to my previous mail, I tried with increasing the array size
> at the producer end, but still getting the same error.
> 
> Also, my producer is running till end, its the consumer which fails. The
> same consumer never fails for Text/Map Messages of any length and of any
> number of messages. So is there any other varibale, that needs to be set, or 
> can it be something related to activemq.xml settings like some stack/heap
> size i have to set.
> 
> Please let me know your inputs.
> 
> Thanks,
> Manu
> 
> manua wrote:
> > 
> > Hi Tim,
> > 
> > I am getting the error, even when my file is just 65 bytes. Its also
> > evident from the output (where I am capturing number of byte recieved). I
> > have posted my output in the previous posts.
> > 
> > Also, if I want to transfer large files (image files of size 100K or
> > more), than what should be the best approach. It will be very nice if you
> > could share some code snippet, explaining this.
> > 
> > Thanks,
> > Manu


My recommendation would be to try and create the simplest possible test
case that demonstrates the issue and open a new Jira issue and attach
the test.  That way it won't get lost and as soon as someone has time to
investigate the issue there will be something for them to use to try and
track down the problem.  

Have you tried to modify the included example app to send BytesMessages
and create in memory byte arrays around the size you are trying to send?
this would demonstrate without requiring any files to be read in that
the AMQCPP code is at fault.

Regards
Tim.


-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message