activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Libraries to include while compiling my activemq-cpp code
Date Fri, 24 Apr 2009 21:11:52 GMT
On Fri, 2009-04-24 at 14:05 -0700, nmittal wrote:
> 
> 
> > It looks like its not using the correct version of APR, which is odd.
> > The `apr_pool_create_unmanaged_ex' didn't exist until APR 1.3 so if
> > that's not being found then it seems as if you are getting an old APR.
> > Have you tried linking against the APR .so files you built instead of
> > the libtool .la files.
> > 
> > Regards
> > Tim.
> > 
> 
> I changed the Makefile to...
> 
> ifeq ($(UNAME), Linux)
> CPPLDFLAGS   = -pipe -fPIC -O3 -m64
> CPPFLAGS     = -I. -I/RSIGrid/amq/activemq-cpp-2.2.5/src/main
> -I/RSIGrid/amq/apr-1.3.3/include -c
> LDFLAGS      = -L/usr/local/lib -L/usr/local/apr/lib
> -L/RSIGrid/amq/apr-util-1.3.4/xml/expat/lib/libexpat.la -m64  
> CC_OUTPUT_FLAG = -o
> CC = g++
> LDLIBS = -lpthread -lactivemq-cpp -lapr-1 -laprutil-1 -luuid -lrt -lcrypt 
> -lpthread -ldl
> endif
> 
> and it built successfully. However, when I try to execute the binary, I get
> the following error...
> 
> $ ./register_ticker 
> ./register_ticker: error while loading shared libraries:
> libactivemq-cpp.so.7: cannot open shared object file: No such file or
> directory
> $
> 
> thanks again for your help.
> Nishant
> 

Probably because its not sitting anywhere that is on the LD_LIBRARY_PATH
or in the ld.so.conf settings.  Either add its location so it can be
found at run time, or link to the static libs by using the .a files
instead of not specifying an extension as that result in the linker
choosing the shared library over the static one.

Regards
Tim.

-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message