activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Building NMS With nant problems
Date Sun, 05 Apr 2009 22:11:01 GMT
On Sat, 2009-04-04 at 23:50 -0700, pdr wrote:
> I found some issues when building nms with nant.  Specifically, the problem
> is the following lines in nant-common.xml:
> 
>   <property name="user.home"
> value="${environment::get-variable('USERPROFILE')}"
>             if="${environment::variable-exists('USERPROFILE') and
> platform::is-windows()}"
>             unless="${property::exists('user.home')}"/>
> 
>   <fail message="The USERPROFILE environment variable is not defined. 
> Please set it to your home directory."
>             unless="${property::exists('user.home')}"
> if="${platform::is-windows()}"/>
> 
> 
> The proper nant function is:
> 
>   <property name="user.home"
> value="${environment::get-variable('USERPROFILE')}"
>             if="${environment::variable-exists('USERPROFILE') and
> platform::is-win32()}"
>             unless="${property::exists('user.home')}"/>
> 
>   <fail message="The USERPROFILE environment variable is not defined. 
> Please set it to your home directory."
>             unless="${property::exists('user.home')}"
> if="${platform::is-win32()}"/>
> 
> 
> 
>   This has probably been found by a lot of different people and I might have
> sync'd an old build from the svn repository.  I searched the forum before I
> registered so it's possible that my search may have been faulty.  Here's
> some more details:
> 
> http://nant.sourceforge.net/release/latest/help/functions/platform.is-win32.html
> 
>   Original error:
> 
> BUILD FAILED
> 
> C:\amq-svn\Apache.NMS.ActiveMQ\nant-common.xml(57,4):
> Unknown function 'platform::is-windows'.
> Expression: ${environment::variable-exists('USERPROFILE') and
> platform::is-windows()}
>                                                              
> ^^^^^^^^^^^^^^^^^^^^^
> 
> Total time: 0.1 seconds.
> 

The current Trunk code for NMS depends on a Nightly Snapshot of NAnt
0.86 which requires the use of the isWindows method as opposed to the
is_win32 method.  You can either grab the latest nant snapshot and build
and install that or make the change that you have pointed out in your
local build file to make it work for you.

Regards
Tim.


-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message