activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex_ynr <suburbanc...@gmail.com>
Subject ActiveMQ Performance Issues
Date Tue, 24 Mar 2009 13:06:43 GMT

Hello,

Our application uses a network bridge between 2 instances of a 5.0.0.23
build of ActiveMQ.

One server is on the internet and the other is on a Local network behind a
firewall. The one behind the firewall initiates the (duplex) connection to
the outside server.

4 different queues are set up . On 3 of those, we have the part of our app
on the intranet server publishing and these are consumed by a different part
of the app on the outside server. The other queue works the other way
around. This queue is also the "critical" one in terms of time for messages
to move from one server to the other.

Our problem is the following. When a message is published to the outside
server and the bridge dies (network disconnection, the local network is
connected to the internet over an adsl line) before the message has reached
the other side, although the bridge reconnects instantly, the message takes
WAY too long to be consumed on the local server.

The traffic is very small (10-20 x 2-3kb messages an hour).

For example:

If a message gets published at 12:00 and the disconnection occurs and by
12:01 it is reconnected, that message might not be consumed until 12:15.
Even though other messages published AFTER the reconnection (say 12:02) will
be consumed almost instantly.

Any ideas?

Thanks,

Alexander Megalokonomos




-- 
View this message in context: http://www.nabble.com/ActiveMQ-Performance-Issues-tp22680003p22680003.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message