activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jn64 <juha.nevalai...@gmail.com>
Subject Re: ActiveMQ and Websphere App Server integration
Date Thu, 19 Mar 2009 07:36:57 GMT

I got this working now =)  
The correct namespace for ActiveMQWASInitialContextFactory is actually
org.apache.activemq.jndi.ActiveMQWASInitialContextFactory.  Note the "WAS"
there is in the middle.  I experienced JNDI lookup failures too, and the key
thing to overcome those was to define the redundant looking custom
properties for the JMS provider (step 4). I set up this additional name
value pair:
java.naming.QueueConnectionFactory  = JMSQueueConnectionFactory. 
Then...success!  

Got one question for you guys - is it possible to set the JMS properties
(for the header) with the WAS admin console, using these custom properties,
or is the only way when composing the message?


rmh1 wrote:
> 
> Whilst I thought that all the earlier steps had gone well, I have since
> restarted my WAS and I am getting a class not found error for the
> initialcontextfactory - which seems strange, I have taken all the .jar
> files from my activeMQ install/lib and have out them in the WAS classpath
> (WAS_INSTALL_ROOT/lib/ext) and have also included a list of all the jars
> added in the classpath field on the "JMS Provider"  settings.
> 
> Anyone had similar problems or know how this might be resolved?
> 
> Thanks
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-and-Websphere-App-Server-integration-tp19741501p22594920.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message