activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MarcusSmith <marc...@hp.com>
Subject org.apache.activemq.broker.region.Topic.send: line 266 NullPointerException
Date Wed, 18 Feb 2009 23:45:03 GMT

I have a situation where a Producer is using a fanout url to a topic, then
producer is being closed.
Sometimes, the broker produces the following error in it's log:

INFO   | jvm 1    | 2009/02/12 13:57:42 | ERROR Service                       
- Async error occurred: java.lang.NullPointerException
INFO   | jvm 1    | 2009/02/12 13:57:42 | java.lang.NullPointerException
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.region.Topic.send(Topic.java:266)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.region.AbstractRegion.send(AbstractRegion.java:350)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.region.RegionBroker.send(RegionBroker.java:437)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.TransactionBroker.send(TransactionBroker.java:224)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.BrokerFilter.send(BrokerFilter.java:126)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.CompositeDestinationBroker.send(CompositeDestinationBroker.java:95)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.MutableBrokerFilter.send(MutableBrokerFilter.java:133)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.TransportConnection.processMessage(TransportConnection.java:450)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.command.ActiveMQMessage.visit(ActiveMQMessage.java:639)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:305)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:179)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:203)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:185)
INFO   | jvm 1    | 2009/02/12 13:57:42 | 	at
java.lang.Thread.run(Thread.java:595)

The code causing the problem is:


final ProducerInfo producerInfo =
producerExchange.getProducerState().getInfo();

Any ideas why getProducerState() would return null?  send() doesn't seem
coded to expect this.

-- 
View this message in context: http://www.nabble.com/org.apache.activemq.broker.region.Topic.send%3A-line-266-NullPointerException-tp22091038p22091038.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message