activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mjustin <michael.jus...@gmx.net>
Subject ProducerTool hangs after 312 messages with --messageSize=2000 --messageCount=500
Date Sat, 07 Feb 2009 10:10:31 GMT

For performance tests on Windows (XP Home SP 3) and AMQ 5.2 (and 5.3
Snapshot), I used the Java ProducerTool with higher values for the
messageSize and messageCount.

I have found that the tool repeatedly "hangs" if I use these increased
values.

After browsing the ActiveMQ docs I realized that this problem can be fixed
by using the persistent flag and setting timeToLive to a low (non-zero)
value. With these additional parameters, I am able to run the ProducerTool
test repeatedly with high values for messageSize and messageCount without
any problems.


Now to the real problem: using my STOMP Delphi implementation, I encounter
the same problem, but here it is not possible to fix it using persistent
messages and reduced time to live. The send times out after a couple of
messages. (But only with high values for size/count).


To examine this, I would like to use the Java implementation of the STOMP
client, but it does not receive the CONNECTED frame after sending the
CONNECT frame. I will try to use other STOMP clients too, maybe I can find a
problem in my own STOMP client.




-- 
View this message in context: http://www.nabble.com/ProducerTool-hangs-after-312-messages-with---messageSize%3D2000---messageCount%3D500-tp21886774p21886774.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message