activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dejan Bosanac" <de...@nighttale.net>
Subject Re: JBoss 4.2.3.GA Embedded AMQ 5.2.0 broker and web console help
Date Fri, 09 Jan 2009 12:02:57 GMT
Hi Eric,

I didn't try embedding web console into JBoss, but from what you said it
seems to me that the problem with your configuration is the default
WEB-INF/webconsole-embedded.xml configuration file that tries to start new
broker instance.

Can you try replacing it with webconsole-invm.xml or the one I provided with
the article and see if it helps?

Cheers
--
Dejan Bosanac

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Thu, Jan 8, 2009 at 9:48 PM, Eric Ma <eric.ma@db.com> wrote:

>
> I embedded AMQ 5.2.0 inside JBoss 4.2.3.GA by following Bruce Snyder's
> article at
> http://activemq.apache.org/integrating-apache-activemq-with-jboss.html.
> That's all working, and I can see the queues I set up from the JBoss
> jmx-console.  Now I am struggling to make the AMQ web console to work in
> the
> same JBoss instance.  I can deploy activemq-web-console-5.2.0.war to JBoss,
> and I see 4 Topics, but I cannot see the queues I set up.  The log file
> shows the following exception when the war is deployed:
>
> 15:04:50,200 INFO  [STDOUT] 2009-01-08 15:04:50,197 [ScannerThread  ] DEBUG
> ManagementContext              - Failed to create local registry
> java.rmi.server.ExportException: Port already in use: 1099;
>
> There have been several threads on this topic:
>
>
> http://www.oreillynet.com/onjava/blog/2007/06/integrating_activemq_web_conso.html
>
> http://www.nabble.com/Web-console-not-working-with-embedded-broker-setup-via-java-with-no-xml-configuration.-td20686813.html
>
> http://www.nabble.com/Embedded-Brokers-%2B-Web-Console-td17467975s2354.html#a17467975
>
> http://www.nabble.com/How-to-monitor-ActiveMQ-that-run-in-JBOSS-td12291171.html#a12291171
>
> http://markmail.org/message/7uwuzidqm4dmhaq7?q=activemq+WebConsole+in+embedded+mode
>
> but there is no single definitive set of steps to follow nor config file
> samples.  Dejan Bosanac's article comes close, but not clear enough (all
> the
> maven stuff made it more confusing :-( )
>
> Can someone post their working config here?  Thanks,
> --
> View this message in context:
> http://www.nabble.com/JBoss-4.2.3.GA-Embedded-AMQ-5.2.0-broker-and-web-console-help-tp21360682p21360682.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message