activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sailaja p <spind...@progress.com>
Subject Re: Unable to start Active MQ Broker without LAN Connection.
Date Fri, 23 Jan 2009 14:10:44 GMT

Your information helped me. 
Thank you. 
Sailaja.


bsnyder wrote:
> 
> On Fri, Jan 16, 2009 at 6:29 AM, sailaja p <spindipr@progress.com> wrote:
>>
>> Hi,
>>
>> I am begginer to the Active MQ and trying understand the features of
>> Active
>> MQ. I have downloaded the Active MQ 5.1.0. When I tried to start the
>> Messaging Broker without LAN Connection I am getting the below
>> exceptions.
>> But if I tried to start the Broker with LAN connection, I am able to
>> start
>> the Broker succesfully.
>>
>> I even tried the above scenario by commenting all network connectors in
>> the
>> broker configuration file (activemq.xml).
>>
>> Is this a limitation or am I doing something wrong? Kindly help me.
> 
> The stack trace indicates that IP multicast must not be enabled on
> your machine. To work around this, edit the conf/activemq.xml and:
> 
> 1) Comment out the default-nc networkConnector. This networkConnector
> uses multicast to automatically discover other ActiveMQ brokers.
> 
> 2) Remove the discoveryUri attribute from the openwire transportConnector.
> 
> After making these changes, ActiveMQ won't use any IP multicast and
> you shouldn't encounter the exception any longer.
> 
> Bruce
> -- 
> perl -e 'print
> unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
> );'
> 
> Apache ActiveMQ - http://activemq.org/
> Apache Camel - http://activemq.org/camel/
> Apache ServiceMix - http://servicemix.org/
> 
> Blog: http://bruceblog.org/
> 
> 

-- 
View this message in context: http://www.nabble.com/Unable-to-start-Active-MQ-Broker-without-LAN-Connection.-tp21499317p21625061.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message