activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rama Casturi <rcast...@transdyn.com>
Subject client ID already connected exception
Date Wed, 21 Jan 2009 22:57:13 GMT

I am getting a InvalidClientIdException during the startup of my application
occasionally and also during runtime. It happens very rarely, but still
happens to be an issue.

http://issues.apache.org/activemq/browse/AMQ-839
http://issues.apache.org/activemq/browse/AMQ-696

Both these mention, it has been fixed but I am still seeing it. I have
deployed 4.1.2 version. My application is a spring based application
deployed inside tomcat as a web application. The stack trace is as follows.

javax.jms.InvalidClientIDException: Broker: DynacJMSServer - Client:
ID:localhost-34942-1231276316699-29:0 already connected
        at
org.apache.activemq.broker.region.RegionBroker.addConnection(RegionBroker.java:204)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:82)
        at
org.apache.activemq.advisory.AdvisoryBroker.addConnection(AdvisoryBroker.java:70)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:82)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:92)
        at
org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:706)
        at
org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:121)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:294)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:185)
        at
org.apache.activemq.transport.ResponseCorrelator.onCommand(ResponseCorrelator.java:95)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:65)
        at
org.apache.activemq.transport.vm.VMTransport.syncOneWay(VMTransport.java:96)
        at
org.apache.activemq.transport.vm.VMTransport.oneway(VMTransport.java:83)
        at
org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:47)
        at
org.apache.activemq.transport.ResponseCorrelator.asyncRequest(ResponseCorrelator.java:69)
        at
org.apache.activemq.transport.ResponseCorrelator.request(ResponseCorrelator.java:74)
        at
org.apache.activemq.ActiveMQConnection.syncSendPacket(ActiveMQConnection.java:1175)
        at
org.apache.activemq.ActiveMQConnection.ensureConnectionInfoSent(ActiveMQConnection.java:1263)
        at
org.apache.activemq.ActiveMQConnection.createSession(ActiveMQConnection.java:276)
        at
org.apache.activemq.ra.ManagedConnectionProxy.createSessionProxy(ManagedConnectionProxy.java:116)
        at
org.apache.activemq.ra.ManagedConnectionProxy.createTopicSession(ManagedConnectionProxy.java:151)

I would appreciate any help or pointers to what the problem could be.

Thanks
-- 
View this message in context: http://www.nabble.com/client-ID-already-connected-exception-tp21593650p21593650.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message