activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: ActiveMQ invalid response
Date Wed, 28 Jan 2009 14:50:05 GMT
This error indicates that we did not receive a WireFormat response from
the Broker when we connected, which could mean that the broker is in a
bad state and is unable to respond to us.  This could be related to an
out of memory situation.

On Wed, 2009-01-28 at 06:40 -0800, Sebastien SOILEN wrote:
> it seems coherent, as we don't use producer flow control. We'll see if longer
> delay helps.
> 
> There is another exception we get sometimes when trying to open connection
> with the broker.We can't really understand its meaning... and how it affects
> the connection. May it be caused by a possible lack of memory too?
> 
> CMSException: OpenWireFormatNegotiator::requestWire format negotiation
> timeout: peer did not send his wire f
> ormat.
>         FILE: activemq/connector/openwire/OpenWireFormatNegotiator.cpp,
> LINE: 98
>         FILE: activemq/connector/openwire/OpenWireFormatNegotiator.cpp,
> LINE: 107
>         FILE: activemq/connector/openwire/OpenWireConnector.cpp, LINE: 1533
>         FILE: activemq/connector/openwire/OpenWireConnector.cpp, LINE: 249
>         FILE: activemq/connector/openwire/OpenWireConnector.cpp, LINE: 186
>         FILE: activemq/core/ActiveMQConnectionFactory.cpp, LINE: 173
> 
> 

-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message