activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Lloyd" <jll...@silvertailsystems.com>
Subject Tips for multiple versions of APR?
Date Fri, 05 Dec 2008 04:22:02 GMT
I think there is a possibility that my problem with my activemq-cpp 2.2.2
consumer locking up is because I messed up with installing apr-1.3.3 and
apr-util-1.3.4 on my CentOS 5.2 system.

A previous version of APR is installed via yum, and too many packages rely
on it in order for me to consider removing it. I tried to install the new
packages in separate directories, but I realize now I specified only
--prefix and not --exec-prefix when I ran ./configure.

I'm going to try to unwind and fix this. But I wonder if anyone else has
good strategies for leaving APR where it is installed by default in CentOS
while having a new version installed in a non-standard place.

Has anyone built apr, apr-util, and activemq-cpp all with static libraries
only, to eliminate any problems with shared library conflicts?

I should mention that I discovered a shared library conflict when I made a
relatively simple change to my modified SimpleAsyncConsumer. I added the use
of some apr_time routines, and then discovered the program would not launch
due to unresolved references in the shared libraries. Adding a directory to
my LD_LIBRARY_PATH allowed the program to run, and it seemed to be running
better than I had seen it so far.

Thanks,
Jim Lloyd

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message