activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: some problems when i start ActiveMQ
Date Thu, 25 Dec 2008 16:36:48 GMT
On Thu, Dec 25, 2008 at 8:47 AM, changemylife <changemylife333@yahoo.com> wrote:
>
> Hello world,
>   I were download apache-activemq-5.2.0. I also set JAVA_HOME. But when I
> run activemq.bat from bin folder. I saw some errors:
>
> ACTIVEMQ_HOME: D:\ACTIVE_MQ_DIR\apache-activemq-5.2.0\bin\..
> ACTIVEMQ_BASE: D:\ACTIVE_MQ_DIR\apache-activemq-5.2.0\bin\..
> Loading message broker from: xbean:activemq.xml
> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
> java.la
> ng.IllegalStateException: Could not find valid implementation for: 2.0
> java.lang.RuntimeException: Failed to execute start task. Reason:
> java.lang.Ille
> galStateException: Could not find valid implementation for: 2.0
>        at
> org.apache.activemq.console.command.StartCommand.runTask(StartCommand
> .java:98)
>        ....
>
>   I tried found to solve my problem at:
> http://issues.apache.org/activemq/browse/SM-839 but I don't known how I can
> do this ! Have some ideas for my problem ?

It looks like you must have a Spring 1.2.x JAR somewhere in your
classpath. This conflicts with ActiveMQ's dependency upon Spring 2.5.x
so just remove the Spring 1.2.x JAR from the classpath and see if the
error disappears.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache Camel - http://activemq.org/camel/
Apache ServiceMix - http://servicemix.org/

Blog: http://bruceblog.org/

Mime
View raw message