activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xordi <jordi...@gmail.com>
Subject JMS serialization problem
Date Sun, 07 Dec 2008 01:51:30 GMT
Hi everyone,
I'm quite new using ActiveMQ. I've been trying to send a java object through
a queue and I get a javax.jms.JMSException: Failed to build body from bytes.
Reason: java.io.IOException:
I've found this bug (https://issues.apache.org/activemq/browse/AMQ-1588),
but I don't know if my problem is because of this bug or if I'm doing
something wrong.
Does anyone know how could I start debugging?
Thanks :)

PD: Here's the code of the class I'm trying to send:
import java.io.Serializable;

public class WhereBlueMessage implements Serializable {

    private static final long serialVersionUID = 4733486888679192093L;
    private Serializable objecte;
    private int tipus;
    public static final int AUTH = 0;
    public static final int QUERY = 1;
    public static final int AUTHANSW = 2;
    public static final int QUERYANSW = 3;
    public static final int INFO = 4;

    public WhereBlueMessage (){}

    public WhereBlueMessage (int Tipus , Serializable Objecte){
        tipus = Tipus;
        objecte = Objecte;
    }

    public Serializable getObject(){
        return objecte;
    }

    public int getTipus(){
        return tipus;
    }

    public void setObject(Serializable Objecte){
        objecte = Objecte;
    }

    public void setTipus(int Tipus){
        tipus=Tipus;
    }

}

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message