activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JeanNiBee <John.Bate...@nuance.com>
Subject Re: Admin Web Console not showing messages in queue.
Date Mon, 08 Dec 2008 15:09:51 GMT

I guess this will be a case of "RTFM" for me. ;)

I just was looking at the Web Console that is provided from the default
'getting started' so I didn't really configure anything other than click the
link in the doc.

Pointer to any info to help me understand this would be great. (As is the
ActiveMQ in action  book in your sig) :)

Thanks


Dejan Bosanac-3 wrote:
> 
> Hi,
> 
> I can't see fro you example how you initialize your web console. Are you
> sure it points to the right broker?
> 
> Cheers
> 
> -- 
> Dejan Bosanac
> 
> 
> http://www.ttmsolutions.com - get a free ActiveMQ user guide
> 
> ActiveMQ in Action - http://www.manning.com/snyder/
> Scripting in Java - http://www.scriptinginjava.net
> 
> 
> 
> JeanNiBee wrote:
>> Hi
>>
>> Using Spring and ActiveMQ in a test environment.
>>
>> I have all my setup working, far as I can tell, as my Sender sends out
>> messages and my MessageListener picks them up.
>>
>> As a test I'm sending 100,000 message through the queue and having my
>> MessageListener sleep for 5 seconds in between each (to ensure build up
>> in
>> the queue itself).
>>
>> When I go to the admin web console and look at the status of my queue it
>> always says '0' doe all four columns of Messages Pending, Consumers,
>> Received and Sent.
>>
>> I keep refreshing to no avail but my listener (that is logging the
>> message
>> text to a file / console) keeps popping a new message to my logs every 5
>> seconds.
>>
>> Not sure how to proceed to debug this. VERY new to using the tool and I
>> admit I got a bit lost running through all the documentation I could
>> find.
>>
>> For kicks.. my spring configs. (Thanks Cyrill LeClerc if you ever read
>> this.. your forum post got me more than just jump started on this)
>>
>> <pre>
>> <bean id="fileUploadController"
>>   class="com.tosg.web.FileUploadController">
>>   <property name="sender" ref="queueSender"/>
>>   <property name="numberOfMessages" value="100000"/>
>>   <property name="listener" ref="messageListener"/>
>> </bean>
>>
>> <bean id="activeMqConnectionFactory"
>>    class="org.apache.activemq.spring.ActiveMQConnectionFactory">
>>    <property name="brokerURL"
>>      
>> value="vm://localhost?broker.persistent=false&amp;broker.useJmx=false"
>> />
>> </bean>
>>
>> <bean id="connectionFactory"
>>    class="org.springframework.jms.connection.SingleConnectionFactory">
>>    <property name="targetConnectionFactory"
>>       ref="activeMqConnectionFactory" />
>> </bean>
>>
>> <bean id="jmsTemplate"
>>    class="org.springframework.jms.core.JmsTemplate">
>>    <property name="connectionFactory" ref="connectionFactory" />
>>    <property name="defaultDestinationName" value="jbtesting" />
>>    <property name="pubSubDomain" value="false" />
>> </bean>
>>
>> <bean id="listenerContainer"
>>   
>> class="org.springframework.jms.listener.DefaultMessageListenerContainer">
>>    <property name="concurrentConsumers" value="5" />
>>    <property name="connectionFactory" ref="connectionFactory" />
>>    <property name="destinationName" value="jbtesting" />
>>    <property name="messageListener" ref="messageListener" />
>> </bean>
>>
>> <bean id="queueSender" class="com.tosg.jms.SampleSender">
>>    <property name="jmsTemplate" ref="jmsTemplate" />
>> </bean>
>>
>> <bean id="messageListener" class="com.tosg.jms.SampleListener" />
>> </pre>
>>
>>   
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Admin-Web-Console-not-showing-messages-in-queue.-tp20889624p20897065.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message