activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Problem of running example in ActiveMQ CMS
Date Sun, 07 Dec 2008 12:19:49 GMT
It looks as if you have another version of APR installed, most likely it
is installed with Ubuntu and it is being found first.  You will either
need to remove it, installed the new version of APR and APR-Util in /usr
or set the LD_LIBRARY_PATH to correctly find your newer version first.

Regards
Tim.

On Sat, 2008-12-06 at 20:52 -0800, arnose wrote:
> Hi, I have compiled ActiveMQ CMS on my Ubuntu 8.10 using APR 1.3.3 and APR
> Util 1.3.4. However when I run make check or example in src directiory, the
> console shows the follwing error: "symbol lookup error:
> /home/chchen/activemq-cpp-2.2.2-src/src/main/.libs/libactivemq-cpp.so.4:
> undefined symbol: apr_pool_create_unmanaged_ex" It seems there is problem on
> my APR or APR Util. But I am not sure what is the problem. Has anyone tried
> or had the answer to solve this? Thank you.
-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message