activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Borja" <adbo...@gmail.com>
Subject Re: Why an embedded broker can be unavailable?
Date Thu, 27 Nov 2008 13:24:39 GMT
Hi Rob ...

Yes .. the broker is started ...

This is the activemq config file (activemq-spring.xml):
_____________________________________________

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:amq="http://activemq.org/config/1.0" xmlns:xsi="
http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
  http://activemq.org/config/1.0 activemq.xsd">

  <!--  lets create an embedded ActiveMQ Broker -->
    <amq:broker useJmx="true" persistent="true">
        <amq:persistenceAdapter>
            <amq:jdbcPersistenceAdapter dataSource="#derby-ds" />
        </amq:persistenceAdapter>
        <amq:transportConnectors>
            <amq:transportConnector uri="tcp://localhost:0" />
        </amq:transportConnectors>
    </amq:broker>

   <!--  ActiveMQ destinations to use  -->
    <amq:queue id="destination"
        physicalName="org.apache.activemq.spring.Test.spring.embedded" />
    <!--
        JMS ConnectionFactory to use, configuring the embedded broker using
        XML
    -->
    <amq:connectionFactory id="jmsFactory" brokerURL="vm://localhost" />
    <bean id="derby-ds" class="org.apache.derby.jdbc.EmbeddedDataSource">
        <property name="databaseName" value="m:/pafII/activemq/derbydb" />
        <property name="createDatabase" value="create" />
    </bean>
</beans>
___________________________________________________________________


In the spring config file, i have added the following line:

<import resource="classpath:/config/activemq-spring.xml" />

When Mule starts, then the activemq jmx serviceurl is shown ...

What could be wrong?


Thanx ...




On Thu, Nov 27, 2008 at 7:28 AM, Rob Davies <rajdavies@gmail.com> wrote:

> so you've started the broker?
>
> On 26 Nov 2008, at 17:22, David Borja wrote:
>
>  Hi activemq users ..
>>
>> I'm having a problem with an embedded broker inside mule.
>>
>> For some reason the broker is getting down and an exception is thrown:
>>
>> ERROR 2008-11-25 09:46:26,826 [ActiveMQ Transport Server:
>> tcp://localhost:0]
>> org.apache.activemq.broker.TransportConnector: Could not accept connection
>> from /172.16.32.49:1291: java.io.IOException: The transport is not
>> running.
>> java.io.IOException: The transport is not running.
>>   at
>>
>> org.apache.activemq.transport.TransportSupport.checkStarted(TransportSupport.java:103)
>>   at
>>
>> org.apache.activemq.transport.tcp.TcpTransport.oneway(TcpTransport.java:117)
>>   at
>>
>> org.apache.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:145)
>>   at
>>
>> org.apache.activemq.transport.TransportFilter.oneway(TransportFilter.java:80)
>>   at
>>
>> org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:93)
>>   at
>>
>> org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:47)
>>   at
>>
>> org.apache.activemq.broker.TransportConnection.dispatch(TransportConnection.java:1138)
>>   at
>>
>> org.apache.activemq.broker.TransportConnection.processDispatch(TransportConnection.java:805)
>>   at
>>
>> org.apache.activemq.broker.TransportConnection.start(TransportConnection.java:885)
>>   at
>>
>> org.apache.activemq.broker.TransportConnector$1.onAccept(TransportConnector.java:148)
>>   at
>>
>> org.apache.activemq.transport.tcp.TcpTransportServer.run(TcpTransportServer.java:167)
>>   at java.lang.Thread.run(Thread.java:570)
>>
>> Thanks
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message