activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully" <gary.tu...@gmail.com>
Subject Re: Some temporary queues are not getting deleted
Date Wed, 05 Nov 2008 11:02:20 GMT
with a call to delete they should be removed, otherwise they are
removed when the connection is closed.
Best thing to do is to produce a test case against trunk and open a
jira issue. There is a existing test for temp queue deletion that
could provide a working template for you:
http://svn.apache.org/viewvc/activemq/trunk/activemq-core/src/test/java/org/apache/activemq/advisory/TempQueueMemoryTest.java?view=markup

2008/11/5 martinhasl <martin.haslinger@fh-vie.ac.at>:
>
> Hi,
>
> I've got the problem that some temporary queues are not getting deleted.
> Actually I am deleting them manually by ((TemporaryQueue)
> tempDest).delete(); as soon as they are not used anymore (and this deletion
> is really called for all my temp-queues as far as I can see) but some of my
> temporary queues are not deleted anyway. It's about 0-10 queues which are
> not getting deleted at 10000 sent messages/creates temporary queues. I have
> also tried it with the latest RC of ActiveMQ 5.2 where I've got the same
> problem.
>
> Could I have forgotten something or could I have missed some configuration?
> What else could I do to get sure all my temp-queues are deleted correctly?
>
> thanks,
> martin
> --
> View this message in context: http://www.nabble.com/Some-temporary-queues-are-not-getting-deleted-tp20339431p20339431.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message