activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From babsD <>
Subject authorizationPlugin and authenticationPlugin
Date Mon, 17 Nov 2008 21:34:19 GMT


I am trying to use my custom authenticationPlugin (which installs a
SimpleAuthenticationBroker) along with an XML definition for the
authorizationPlugin as follows in the activemq.xml file:

   <bean id="MYAuthenticationPlugin"

   <broker xmlns=""
brokerName="localhost" dataDirectory="${activemq.base}/data"


      <authorizationEntry queue=">" read="ADMIN" write="ADMIN" admin="ADMIN"
      <authorizationEntry queue="TOOL.>" read="USER" write="USER"
admin="ADMIN" />
      <authorizationEntry topic=">" read="ADMIN" write="ADMIN" admin="ADMIN"
      <authorizationEntry topic="TOOL.>" read="USER" write="USER"
admin="ADMIN" />
      <authorizationEntry topic="ActiveMQ.Advisory.>" read="ADMIN,USER"
          write="ADMIN,USER" admin="ADMIN,USER"/>

<tempDestinationAuthorizationEntry read="tempDestinationAdmins"
write="tempDestinationAdmins" admin="tempDestinationAdmins"/>




The problem I have is when I define <plugins>, it takes over and
MYAuthenticationPlugin isn't installed.  Is there some way to put "two"
plugins in the defintion for the <broker>?  Or is there a way I can refer to
MYAuthenticationPlugin in the <plugins> section?  I have tried a lot of
things with no success getting both of there pieces of the security pie.

Any ideas would be greatly appreciated,


View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message