activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GiveMeLifeSupport <manish.bha...@gmail.com>
Subject Re: Difficulty with interoperating XMPP clients with ActiveMQ 5 (FUSE Message Broker 5.0.0.2)
Date Tue, 11 Nov 2008 18:45:14 GMT

I am running into the same issue. Fintan were you able to resolve this issue?

Regards
Manish


Fintan Bolton wrote:
> 
> I've tried to follow the steps for connecting a Spark client to an
> activemq message broker (as described in the XMPP page,
> http://activemq.apache.org/xmpp.html), but I've found that the step, 
> "Join a Conference Room", does not work.  I am using a Spark 2.5.7 client
> and ActiveMQ 5
> on the Windows platform.
> 
> Here's what happens when I try to follow the steps in the tutorial:
> 
> 1. I start up the 'activemq' message broker, which has an XMPP connector
> with URL, xmpp://localhost:61222. The XMPP endpoint start up without
> error.
> 
> 2. I start up the Spark 2.5.7 client. Using the Advanced options, I have
> already disabled the automatic host discover feature.
> 
> 3. I log in to the server, localhost:61222, using an arbitrary username
> and password.  This causes the activemq broker to log the following
> warnings to the screen:
> 
> WARN  ProtocolConverter              - Iq Unknown  to: null type: get
> from: null
>  id: 0y8oX-4 element namespace:
> http://www.jivesoftware.org/protocol/sharedgroup
>  localName: sharedgroup
> WARN  ProtocolConverter              - Iq Unknown  to: null type: get
> from: tyba
> lt@localhost/spark id: 0y8oX-5 element namespace: vcard-temp localName:
> vCard    
> 
> 4. Now I try to click the 'Join Conference Room' button on the Spark
> client.  Nothing happens!  Or rather, all that happens is that the little
> button remains greyed out for a while (almost as if it's waiting for a
> response, but I'm not sure if it's talking to the broker, because nothing
> is logged in the broker command window).
> 
> Has anyone an idea what I'm doing wrong here?  I've tried using other
> Jabber clients (e.g. Pidgin and Psi), but with those clients I cannot even
> log in.
> 
> Cheers,
> Fintan
> 

-- 
View this message in context: http://www.nabble.com/Difficulty-with-interoperating-XMPP-clients-with-ActiveMQ-5-%28FUSE-Message-Broker-5.0.0.2%29-tp13096422p20445754.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message