activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Ye <edwar...@21cn.com>
Subject Async error occurred: java.lang.IllegalArgumentException: The subscription does not exist
Date Thu, 06 Nov 2008 03:28:17 GMT

Hi,all.
I have a simple test with ActiveMQ 5.1.0 and activemq-cpp-2.2.1 run on
Windows 2003 .
The producer sends persistent messages into a queue and it works fine ,
Except that sometimes Asyc error occurs after several thousands messages
sent.

The following error shown on the console:
2008-11-05 23:26:41,843 [/127.0.0.1:2994] ERROR Service                       
- Async error occurred: java.lang.IllegalArgumentException: The subscription
does not exist: 4a48f4c6-9d63-11b3-2e85-0000d487ce8a:0:0
java.lang.IllegalArgumentException: The subscription does not exist:
4a48f4c6-9d63-11b3-2e85-0000d487ce8a:0:0
	at
org.apache.activemq.broker.region.AbstractRegion.acknowledge(AbstractRegion.java:357)
	at
org.apache.activemq.broker.region.RegionBroker.acknowledge(RegionBroker.java:470)
	at
org.apache.activemq.broker.TransactionBroker.acknowledge(TransactionBroker.java:194)
	at
org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:73)
	at
org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:73)
	at
org.apache.activemq.broker.MutableBrokerFilter.acknowledge(MutableBrokerFilter.java:84)
	at
org.apache.activemq.broker.TransportConnection.processMessageAck(TransportConnection.java:443)
	at org.apache.activemq.command.MessageAck.visit(MessageAck.java:196)
	at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:292)
	at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:180)
	at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
	at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
	at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
	at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
	at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:196)
	at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:183)
	at java.lang.Thread.run(Thread.java:619)

This message happens each time the test is running. 
I am new to ActiveMQ, and hope someone could help.
Thanks.

-- 
View this message in context: http://www.nabble.com/Async-error-occurred%3A-java.lang.IllegalArgumentException%3A-The-subscription-does-not-exist-tp20354507p20354507.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message