activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: Store and forward not working?
Date Tue, 14 Oct 2008 00:13:51 GMT
I don't see anything obviously wrong with the config files.  I
normally give each networkConnector a unique name attribute, but I
don't think that would cause it to not work.  I don't typically use
the Web console, though (I think issues like the negative message
count are known) -- to test it "the old-fashioned way" I'd just send
messages to one of the brokers and attach listeners to both brokers
and make sure each listener sees some messages.  You may have to send
a large number of messages to see significant "load balancing" across
the network, though.  (I know there are some settings that affect
this, but as I recall the default is not to always send messages to
local clients so I would expect to see some load balancing happening.)

Thanks,
       Aaron

On Mon, Oct 13, 2008 at 4:58 PM, jpoloney <jpoloney@gmail.com> wrote:
>
> I rebooted queue1 and looked in the data/activemq.log file and saw the
> following line:
>
> 2008-10-13 13:55:45,311 [$Worker@17b1d64] INFO  DemandForwardingBridge
> - Network connection between vm://queue1#0 and
> tcp:///10.17.48.92:61616(queue2) has been established.
>
> Does this mean that it's working? How would I test it? I'm looking at the
> pending messages on the web console, and they're all over the place. I
> really don't get how it works (sometimes I have negative pending messages?)
> Is there any good way to determine that it's actually working?
>
> Thanks,
>
> -- Joel
>
>
> jpoloney wrote:
>>
>> Here they are:
>>
>>  http://www.nabble.com/file/p19962668/queue1.xml queue1.xml
>>  http://www.nabble.com/file/p19962668/queue2.xml queue2.xml
>>
>> Thanks,
>>
>> -- Joel
>>
>>
>> ammulder wrote:
>>>
>>> Could you post the config files for both servers just for a sanity check?
>>>
>>> Thanks,
>>>       Aaron
>>>
>>>
>>
>>
>
> --
> View this message in context: http://www.nabble.com/Store-and-forward-not-working--tp19937282p19962811.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>
>

Mime
View raw message