activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Datacom - Marcelo <marc...@datacom.ind.br>
Subject Re: NIO freezes client
Date Fri, 31 Oct 2008 20:25:02 GMT
After changing clients to tcp and let broker to nio it passes the freeze 
point but crashes with this log in client:

(common.messaging.SessionMessage) is our class not from activemq.
........
[org.apache.activemq.transport.WireFormatNegotiator] DEBUG: Sending: 
WireFormatInfo { version=3, properties={CacheSize=1024, 
CacheEnabled=true, SizePrefixDisabled=false, 
MaxInactivityDurationInitalDelay=10000, TcpNoDelayEnabled=true, 
MaxInactivityDuration=30000, TightEncodingEnabled=true, 
StackTraceEnabled=true}, magic=[A,c,t,i,v,e,M,Q]}
[31/10/2008 17:21:39] [common.messaging.SessionMessage] DEBUG: Created 
connection..
[31/10/2008 17:21:39] [org.apache.activemq.transport.tcp.TcpTransport] 
DEBUG: TCP consumer thread starting
[31/10/2008 17:21:49] [org.apache.activemq.transport.InactivityMonitor] 
DEBUG: Message received since last read check, resetting flag:
[31/10/2008 17:21:49] [org.apache.activemq.transport.InactivityMonitor] 
DEBUG: Message sent since last write check, resetting flag
[31/10/2008 17:21:49] [common.messaging.SessionMessage] ERROR: Error 
initializing Message Client. Will sleep and try again. Retry:1  Verify 
if JMS server is running.
javax.jms.JMSException: Wire format negotiation timeout: peer did not 
send his wire format.
    at 
org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:62)
    at 
org.apache.activemq.ActiveMQConnection.syncSendPacket(ActiveMQConnection.java:1206)
    at 
org.apache.activemq.ActiveMQConnection.ensureConnectionInfoSent(ActiveMQConnection.java:1289)
    at 
org.apache.activemq.ActiveMQConnection.createSession(ActiveMQConnection.java:295)
    at 
org.apache.activemq.ActiveMQConnection.createTopicSession(ActiveMQConnection.java:998)


Rob Davies escreveu:
> Use tcp:// for the clients - nio works for the broker only
>
> On 31 Oct 2008, at 17:42, Datacom - Marcelo wrote:
>
>> Hi, we are using  AMQ 5.1.0 and tried to change from Openwire to NIO 
>> changing from
>> <transportConnectors>
>>      <transportConnector name="DefaultConnector" 
>> uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=30000"/>
>> </transportConnectors>
>>
>> to
>>
>> <transportConnectors>
>>      <transportConnector name="DefaultConnector" 
>> uri="nio://localhost:61616?wireFormat.maxInactivityDuration=30000"/>
>> </transportConnectors>
>>
>> the server starts perfectly but all the clients freezes and no 
>> message is transmited. The client URI changes from:
>> "tcp://localhost:61616" to "nio://localhost:61616"
>>
>> Enabling log in server all lines are identicall in the begining, 
>> changing in:
>>
>> WORKING (tcp)
>> 2008-10-31 14:24:25,468 [/127.0.0.1:2826] DEBUG 
>> WireFormatNegotiator           - Sending: WireFormatInfo { version=3, 
>> properties={CacheSize=1024, CacheEnabled=true, 
>> SizePrefixDisabled=false, MaxInactivityDurationInitalDelay=10000, 
>> TcpNoDelayEnabled=true, MaxInactivityDuration=30000, 
>> TightEncodingEnabled=true, StackTraceEnabled=true}, 
>> magic=[A,c,t,i,v,e,M,Q]}
>>
>> NON-WORKING (nio)
>>
>> 2008-10-31 14:20:11,250 [itor WriteCheck] DEBUG 
>> InactivityMonitor              - 10000 ms elapsed since last write 
>> check.
>>
>>
>> And the client freezes.
>>
>> Are there any limitation to use nio ? We are using 
>> publisher/subscriber messages.
>>
>> Thanks in advance.
>>
>> -- 
>> MARCELO Ribeiro
>>
>>
>
>

-- 
MARCELO Ribeiro




Mime
View raw message