activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: NIO freezes client
Date Fri, 31 Oct 2008 19:56:50 GMT
Use tcp:// for the clients - nio works for the broker only

On 31 Oct 2008, at 17:42, Datacom - Marcelo wrote:

> Hi, we are using  AMQ 5.1.0 and tried to change from Openwire to NIO  
> changing from
> <transportConnectors>
>      <transportConnector name="DefaultConnector" uri="tcp:// 
> localhost:61616?wireFormat.maxInactivityDuration=30000"/>
> </transportConnectors>
>
> to
>
> <transportConnectors>
>      <transportConnector name="DefaultConnector" uri="nio:// 
> localhost:61616?wireFormat.maxInactivityDuration=30000"/>
> </transportConnectors>
>
> the server starts perfectly but all the clients freezes and no  
> message is transmited. The client URI changes from:
> "tcp://localhost:61616" to "nio://localhost:61616"
>
> Enabling log in server all lines are identicall in the begining,  
> changing in:
>
> WORKING (tcp)
> 2008-10-31 14:24:25,468 [/127.0.0.1:2826] DEBUG  
> WireFormatNegotiator           - Sending: WireFormatInfo  
> { version=3, properties={CacheSize=1024, CacheEnabled=true,  
> SizePrefixDisabled=false, MaxInactivityDurationInitalDelay=10000,  
> TcpNoDelayEnabled=true, MaxInactivityDuration=30000,  
> TightEncodingEnabled=true, StackTraceEnabled=true},  
> magic=[A,c,t,i,v,e,M,Q]}
>
> NON-WORKING (nio)
>
> 2008-10-31 14:20:11,250 [itor WriteCheck] DEBUG  
> InactivityMonitor              - 10000 ms elapsed since last write  
> check.
>
>
> And the client freezes.
>
> Are there any limitation to use nio ? We are using publisher/ 
> subscriber messages.
>
> Thanks in advance.
>
> -- 
> MARCELO Ribeiro
>
>


Mime
View raw message