activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From selezovikj <semir.elezo...@gmail.com>
Subject Re: Failover transport
Date Fri, 24 Oct 2008 10:40:07 GMT


I saw that in the Apache ActiveMq 5.2 release the default
ActiveMQConnectionFactory brokerUrl  uses the failover transport.
Is this going to solve my problem ? 

I tried running my application on different machines and it is giving the
same error. Can anyone suggest anything ? 





selezovikj wrote:
> 
> Even only: 
> 
> failover://tcp://localhost:61617
> 
> does not work
> 
> 
> 
> selezovikj wrote:
>> 
>> I have a jms appender sending logging events to active mq broker. In the
>> jndi.properties I have the following provider url:
>> 
>> java.naming.provider.url =
>> failover:(tcp://localhost:61617,tcp://localhost:61616)?initialReconnectDelay=20&maxReconnectDelay=1000&randomize=false&maxReconnectAttempts=10
>> 
>> 
>> Since randomize is set to false, I am expecting it to connect to
>> tcp://localhost:61617 first. It attempts to connect to it, but I just get
>> the following message:
>> 
>> [2008-10-23 13:25:56,808]
>> org.apache.activemq.transport.failover.FailoverTransport DEBUG  - Waking
>> up reconnect task
>> [2008-10-23 13:25:56,813]
>> org.apache.activemq.transport.failover.FailoverTransport DEBUG  -
>> Attempting connect to: tcp://localhost:61617
>> 
>> When I set the providerURL in my jndi.properties to only
>> "tcp://localhost:61617", it connects successfully.
>> As I see in the TCP transport there is not an option that would make my
>> jms appender reconnect to the server, once the server is shut down and
>> restarted.
>> 
>> Any help with this ? 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Failover-transport-tp20130356p20147844.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message