activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zog <jogouss...@gmail.com>
Subject weblogic support and <destination-jndi-name>
Date Tue, 07 Oct 2008 19:13:03 GMT

Hi
I'm porting MDBs developed for weblogic into OpenEJB. I have the following
issue.
I declared the queues I use in openejb.xml, like
<Resource id="My_JNDI_QUEUE"
          type="javax.jms.Queue">
  destination My_Real_Queue
</Resource>
and my weblogic.xml descriptors contain
  <weblogic-enterprise-bean>
    <ejb-name>MyMDB</ejb-name>
    <message-driven-descriptor>
      <destination-jndi-name>My_JNDI_Queue</destination-jndi-
name>
If I use just this (hoping that OpenEJB will fully support my
weblogic-ejb-jar.xml) then
the embedded instance of activemq seems to create a queue named
queue://MyMDB
instead of 
queue://My_Real_Queue 
i.e. the lookup from the JNDI name to the real name is not done.
However, if I add
        <activation-config-property>
         
<activation-config-property-name>destination</activation-config-property-name>
         
<activation-config-property-value>My_Real_Queue</activation-config-property-value>
        </activation-config-property>
then the queue is properly created and all works well.
So - question is: am I right to assume OpenEJB doesn't support the
<destination-jndi-name> in weblogic descriptors or is my configuration
screwed up somehow ?
Can you confirm one or the other :) ?
Thanks
        /jog
-- 
View this message in context: http://www.nabble.com/weblogic-support-and-%3Cdestination-jndi-name%3E-tp19865209p19865209.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message