activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: ActiveMQ 5.1 Start Stop
Date Fri, 26 Sep 2008 17:32:03 GMT
On Fri, Sep 26, 2008 at 8:27 AM, spatel <saad.patel@gmail.com> wrote:
>
> Anyone know the cause of this problem? Is my configuration wrong?
>
> Any help would be greatly appreciated.
> Thanks!
>
> spatel wrote:
>>
>> I am trying to use a port other than the default 1099. I'm using port
>> 4099, but I get the following when I run activemq-admin stop:
>> <br>
>> <small>Error: Exception thrown by the agent :
>> java.rmi.server.ExportException: Port already in use: 4099; nested
>> exception is:
>>       java.net.BindException: Address already in use</small>
>> <br>
>> Setting for activemq-admin is:
>> SUNJMX="-Dcom.sun.management.jmxremote
>> -Dcom.sun.management.jmxremote.port=4099
>> -Dcom.sun.management.jmxremote.authenticate=false
>> -Dcom.sun.management.jmxremote.ssl=false"
>>
>> I also have useJms="true" in my activemq.xml file.
>>
>> Any suggestions?

I just tested this using ActiveMQ 5.1.0. To stop the broker using the
activemq-admin script, I had to edit the conf/activemq.xml file to
create a JMX connector like so:

<managementContext>
    <managementContext createConnector="true"/>
</managementContext>

Then I started the broker in one terminal and in another terminal, I
executed ./bin/activemq-admin stop and the broker shut down just fine
in the first terminal.

I did not need to edit the activemq-admin script at all.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache Camel - http://activemq.org/camel/
Apache ServiceMix - http://servicemix.org/

Blog: http://bruceblog.org/

Mime
View raw message