activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: The connection to x.x.x.x:x is taking a long time to shutdown
Date Wed, 10 Sep 2008 21:42:25 GMT
On Wed, Sep 10, 2008 at 10:10 AM, Yari Marchetti
<yari.marchetti@staff.dada.net> wrote:
> Hi,
> today i was testing a client application with ActiveMQ broker
> using STOMP transport, and after some tests i saw 27 different
> consumers connected to that queue by looking at the web console.
> This is impossible because the broker is on my machine and i was
> the only one accessing it.
>
> By looking at netstat i saw 27 CLOSED_WAIT different connections
> to the stomp transport port, and the clients were all gone by long.
> So i tried to stop the broker and got an unending list of
>
> The connection to '/x.x.x.x:x' is taking a long time to shutdown
>
> repetead by 5 seconds, and the broker never stopping so that i had
> to kill it.
>
> The tests were somewhat unusual, with a lot of abruptly interruptions,
> but i think this isn't the normal behavior for the broker, isn't it?

Please describe the behavior of your cilents more (and post code if
possible). Were you connecting and disconnecting over and over on the
STOMP transport in your tests?

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache Camel - http://activemq.org/camel/
Apache ServiceMix - http://servicemix.org/

Blog: http://bruceblog.org/

Mime
View raw message