activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Chekan" <kot.bege...@gmail.com>
Subject Re: Can't delete a queue
Date Sun, 14 Sep 2008 02:44:39 GMT
Ok, I've spent some time with debugger and I see that AMQMessageStore
does not implement any function which would allow to delete a queue.
Broker's removeDestianation calls Queue.dispose() which calls
AMQMessageStore.removeAllMessages().
Than I'm puzzled why in web admin tool there is "purge" and "delete"
when delete means "delete from memory" but leaves a queue in
persistence storage.

Vadim.

On Fri, Sep 12, 2008 at 8:49 PM, Vadim Chekan <kot.begemot@gmail.com> wrote:
> I can't believe it is just me.
> I've just downloaded activemq-snapshot-20080907, did no configurations
> at all, just unzip it and ran in the console.
> Than wen to web admin console, create a queue 'aaa' from web console,
> purged it from web console.
> Restarted activemq. The queue 'aaa' is back.
> Could anybody confirm that it is/isn't reproducible please?
>
> Vadim.
>
> On Tue, Sep 9, 2008 at 4:37 PM, Vadim Chekan <kot.begemot@gmail.com> wrote:
>> No, and there are several of them which once created can not be deleted.
>> I can reproduce it under linux and windows.
>> I create a queue using NMS and than I attempt to delete it either with
>> web admin console or jconsole. I'll play with it more at home today
>> and may be will be able to find some new details. Meanwhile if you can
>> hint where to set breakpoints I'll be able to debug it.
>>
>> Vadim.
>>
>> On Tue, Sep 9, 2008 at 1:47 AM, James Strachan <james.strachan@gmail.com> wrote:
>>> The queue isn't mentioned in the activemq.xml file right?
>>>
>>> 2008/9/8 Vadim Chekan <kot.begemot@gmail.com>:
>>>> Hi all,
>>>> If I delete a queue, it is back after I restart ActiveMQ. I tried
>>>> deleting from admin web console and from jconsole. The same result
>>>> Activemq-5.1.0
>>>> Pesistence configuration is from the standard config file:
>>>>        <persistenceAdapter>
>>>>            <amqPersistenceAdapter syncOnWrite="false"
>>>> directory="${activemq.base}/data" maxFileLength="20 mb"/>
>>>>        </persistenceAdapter>
>>>>
>>>>
>>>> Any ideas what could be wrong?
>>>>
>>>> --
>>>> From RFC 2631: In ASN.1, EXPLICIT tagging is implicit unless IMPLICIT
>>>> is explicitly specified
>>>>
>>>
>>>
>>>
>>> --
>>> James
>>> -------
>>> http://macstrac.blogspot.com/
>>>
>>> Open Source Integration
>>> http://open.iona.com
>>>
>>
>>
>>
>> --
>> From RFC 2631: In ASN.1, EXPLICIT tagging is implicit unless IMPLICIT
>> is explicitly specified
>>
>
>
>
> --
> From RFC 2631: In ASN.1, EXPLICIT tagging is implicit unless IMPLICIT
> is explicitly specified
>



-- 
>From RFC 2631: In ASN.1, EXPLICIT tagging is implicit unless IMPLICIT
is explicitly specified

Mime
View raw message