activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: On Restarting ActiveMQ my Old Queues get deleted.
Date Mon, 01 Sep 2008 06:52:35 GMT
ok - comment out the memory persistent adaptor - in your config -  
which only keeps messages in memory. ActiveMQ will then use the  
default - which stores messages on your local disk


cheers,

Rob

Rob Davies
http://rajdavies.blogspot.com/


On 1 Sep 2008, at 06:12, Jigar Naik wrote:

>
> Nopes i m sending persistent messages. Bellow is my producer code
>
> public static void startSendMessage(String queueName){
> 		try{
> 			Producer.connectionFactory 	= new
> ActiveMQConnectionFactory("tcp://localhost:61616");
> 			Producer.connection 		= connectionFactory.createConnection();
> 			Producer.connection.start();
> 			Producer.session 			= connection.createSession(false,
> Session.AUTO_ACKNOWLEDGE);
> 			Producer.destination 		= session.createQueue(queueName);
> 			Producer.producer 			= session.createProducer(destination);
> 			Producer.producer.setDeliveryMode(DeliveryMode.PERSISTENT);
> 			Producer.textMessage = session.createTextMessage();
> 		}catch(Exception e){
> 			e.printStackTrace();
> 		}
> 	}
>
> it has to be something with configuration file. please find the  
> attached
> configuration file. and guide me for the same.
>
> http://www.nabble.com/file/p19248986/activemq.xml activemq.xml
>
>
>
> rajdavies wrote:
>>
>>
>> On 1 Sep 2008, at 05:49, Jigar Naik wrote:
>>
>>>
>>> Hi,
>>>
>>> I am facing problem with activeMQ, the problem is when i restart the
>>> activeMQ, my old queues get deleted and i am loosing the messages in
>>> that
>>> queue,
>>>
>>> Is this a configuration issue in activemq.xml file ?
>>> -- 
>>> View this message in context:
>>> http://www.nabble.com/On-Restarting-ActiveMQ-my-Old-Queues-get-deleted.-tp19248879p19248879.html
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>
>>
>> Its either down to the configuration you are using - or that you are
>> sending messages with a NON_PERSISTENT DeliveryMode ?
>>
>>
>>
>> cheers,
>>
>> Rob
>>
>> Rob Davies
>> http://rajdavies.blogspot.com/
>>
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/On-Restarting-ActiveMQ-my-Old-Queues-get-deleted.-tp19248879p19248986.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message