activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <dejan.bosa...@ttmsolutions.com>
Subject Re: Failing to read messages, AMQ5.0.0, Stomp
Date Tue, 02 Sep 2008 09:28:56 GMT
Hi Joel,

it seems to me like you are trying to read from an empty queue.

Did you try some of the monitoring techniques
(http://activemq.apache.org/how-can-i-monitor-activemq.html) to see the
state of the broker (and particular queues)?

Regards

-- 
Dejan Bosanac


http://www.ttmsolutions.com - get a free ActiveMQ user guide

ActiveMQ in Action - http://www.manning.com/snyder/
Scripting in Java - http://www.scriptinginjava.net



jpoloney wrote:
> Hey all,
>
> I am having a strange problem in that I am unable to read from one of my
> queues in a AMQ 5.0.0/Stomp setup. I am using the Kaha persistent store (all
> messages are set as persistent). When I start the broker (loading old
> messages into the queue), after a while it gets into a state where I can no
> longer read from the queue. I have no problems producing to this specific
> queue.
>
> I started examining the messages that I was getting back from the Stomp
> client (reading the sockets). I am able to connect to the queue
> successfully, but cannot read any frames afterwards. The stomp client reads
> 1 character at a time and unless it hits the end of the file, the only other
> time it finishes reading is if it hits a null character followed by a new
> line (in that order specifically). When I was debugging it, I was
> consistently getting null characters, and thus it would never break out
> (infinite loop).
>
> Is there any way to look at the top level message on the queue through some
> kind of debugging tool? My guess is that for whatever reason, one of the
> messages became corrupted and everything is failing on it.
>
> Has anyone else ran into this kind of issue before? Any known ways to get
> around it?
>
> Thanks,
>
> -- Joel
>   



Mime
View raw message