activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bradley Schaefer" <brad...@beboinc.com>
Subject Re: ActiveMQ and Resin with JCA
Date Tue, 02 Sep 2008 19:50:35 GMT
Are you acknowledging your consumed messages?

On Tue, Sep 2, 2008 at 12:38 PM, regvito <reggie.vito@copart.com> wrote:

>
> Hi,
>
> I am using the Resin 3.2 version with a Message Driven Bean listening to an
> ActiveMQ Queue remotely connected through JCA with the ActiveMQ 5.1.0 RAR
> file. Below is my configuration in the resin-web.xml
>
> <web-app xmlns="http://caucho.com/ns/resin">
> <resource-adapter class="org.apache.activemq.ra.ActiveMQResourceAdapter">
>    <init server-url="tcp://localhost:61616"/>
> </resource-adapter>
>  <connection-factory
> class="org.apache.activemq.ra.ActiveMQManagedConnectionFactory"
> name="manfactory"/>
>
>  <jms-queue name="testResinConQueue"
> class="org.apache.activemq.command.ActiveMQQueue">
>  <init physicalName="testResinConQueue"/>
>  </jms-queue>
>
> <ejb-message-bean class="com.test.ejb.ConsumerMessageBean">
>  <destination>#{testResinConQueue}</destination>
>  </ejb-message-bean>
> </web-app>
>
> The issue i am observing is that although i see the messages being
> delivered
> to the MDB successfully, the messages themseleves are not fully removed
> from
> the ActiveMQ Queue resulting in the MDB receiving the same messages
> everytime resin starts.
>
> Any help on this would be appreciated?
>
> Thanks in advance.
> --
> View this message in context:
> http://www.nabble.com/ActiveMQ-and-Resin-with-JCA-tp19276889p19276889.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message