activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Fernandez <joe.fernan...@ttmsolutions.com>
Subject Re: Security - simpleAuthenticationPlugin - SecurityException: User name or password is invalid.
Date Thu, 18 Sep 2008 11:12:08 GMT

The client @ 172.19.161.51 is trying to connect with an invalid
username/password. 

Is the broker actually terminating when it throws the SecurityException?

Joe
Get a free ActiveMQ user guide @ http://www.ttmsolutions.com 



UT wrote:
> 
> Hi,
> 
> i try to start activemq 5.1 with the simpleAuthenticationPlugin. When the
> server starts, I get the following exception:
> 
> DEBUG WireFormatNegotiator           - tcp:///172.19.161.51:1465 after
> negotiation: OpenWireFormat{version=3, cacheEnabled=true,
> codingEnabled=true, sizePrefixDisabled=false}
> INFO  TransportServerThreadSupport   - Listening for connections at:
> ssl://B4022-C:61617
> INFO  TransportConnector             - Connector ssl Started
> INFO  TransportServerThreadSupport   - Listening for connections at:
> stomp://B4022-C:61613
> INFO  TransportConnector             - Connector stomp Started
> DEBUG TransportConnection            - Setting up new connection:
> /172.19.161.51:1465
> WARN  TransportConnection            - Failed to add Connection
> java.lang.SecurityException: User name or password is invalid.
>         at
> org.apache.activemq.security.SimpleAuthenticationBroker.addConnection(SimpleAuthenticationBroker.java:52)
>         at
> org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:81)
>         at
> org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:88)
>         at
> org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:662)
>         at
> org.apache.activemq.broker.jmx.ManagedTransportConnection.processAddConnection(ManagedTransportConnection.java:86)
>         at
> org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:125)
>         at
> org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:292)
>         at
> org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:180)
>         at
> org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
>         at
> org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
>         at
> org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
>         at
> org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
>         at
> org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:196)
>         at
> org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:183)
>         at java.lang.Thread.run(Unknown Source)
> 
> 
> Here is my activemq configuration:
> 
> 
> <beans xmlns="http://www.springframework.org/schema/beans"
> xmlns:amq="http://activemq.apache.org/schema/core"
> 	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> 	xsi:schemaLocation="http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
>   http://activemq.apache.org/schema/core
> http://activemq.apache.org/schema/core/activemq-core.xsd   
>   http://activemq.apache.org/camel/schema/spring
> http://activemq.apache.org/camel/schema/spring/camel-spring.xsd">
> 	<!-- Allows us to use system properties as variables in this
> configuration file -->
> 	<bean
> class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"
> />
> 	<broker xmlns="http://activemq.org/config/1.0" brokerName="localhost"
> dataDirectory="${activemq.base}/data">
> 
> 		<!-- The transport connectors ActiveMQ will listen to -->
> 		<transportConnectors>
> 			<transportConnector name="openwire" uri="tcp://localhost:61616"
> discoveryUri="multicast://default" />
> 			<transportConnector name="ssl" uri="ssl://localhost:61617" />
> 			<transportConnector name="stomp" uri="stomp://localhost:61613" />
> 			<transportConnector name="xmpp" uri="xmpp://localhost:61222" />
> 		</transportConnectors>
> 		<!-- The store and forward broker networks ActiveMQ will listen to -->
> 		<networkConnectors>
> 			<networkConnector name="default-nc" uri="multicast://default" />
> 		</networkConnectors>
> 		<plugins>
> 			<!-- use JAAS to authenticate using the login.config file on the
> classpath to configure JAAS -->
> 			<simpleAuthenticationPlugin>
> 				<users>
> 					<authenticationUser username="system" password="manager"
> groups="users,admins" />
> 					<authenticationUser username="user" password="password"
> groups="users" />
> 					<authenticationUser username="guest" password="password"
> groups="guests" />
> 				</users>
> 			</simpleAuthenticationPlugin>
> 			<!-- lets configure a destination based authorization mechanism -->
> 			<authorizationPlugin>
> 				<map>
> 					<authorizationMap>
> 						<authorizationEntries>
> 							<authorizationEntry queue=">" read="all" write="all" admin="all" />
> 							<authorizationEntry topic="ActiveMQ.Advisory.>" read="all"
> write="all" admin="all" />
> 						</authorizationEntries>
> 						<tempDestinationAuthorizationEntry>
> 							<tempDestinationAuthorizationEntry read="all" write="all"
> admin="all" />
> 						</tempDestinationAuthorizationEntry>
> 					</authorizationMap>
> 				</map>
> 			</authorizationPlugin>
> 		</plugins>
> 	</broker>	
> </beans>
> 
> When I remove the openwire transport connector the server starts. But I
> need this connector, I can't remove it.
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Security---simpleAuthenticationPlugin---SecurityException%3A-User-name-or-password-is-invalid.-tp19548564p19550477.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message