activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jpoloney <jpolo...@gmail.com>
Subject Re: Failing to read messages, AMQ5.0.0, Stomp
Date Tue, 02 Sep 2008 18:41:08 GMT

Hi Dejan,

The queue is definitely not empty. Either that, and then receives some
messages, but then is never able to read them again. I am looking at it
right now and there is 160,000 messages waiting to be consumed, but my
consumer is failing to read them.

I restarted the consumer and it consumed about 400 messages, and then
stopped. Further respawning of consumers doesn't appear to be do anything.
The ActiveMQ admin console definitely shows the messages, but the consumer
isn't doing anything.

The other weird thing is, if I restart the message queue (and it loads all
the persistent messages in), then it has no problems reading them again.

Any thoughts?

-- Joel


Dejan Bosanac-3 wrote:
> 
> Hi Joel,
> 
> it seems to me like you are trying to read from an empty queue.
> 
> Did you try some of the monitoring techniques
> (http://activemq.apache.org/how-can-i-monitor-activemq.html) to see the
> state of the broker (and particular queues)?
> 
> Regards
> 
> -- 
> Dejan Bosanac
> 
> 
> http://www.ttmsolutions.com - get a free ActiveMQ user guide
> 
> ActiveMQ in Action - http://www.manning.com/snyder/
> Scripting in Java - http://www.scriptinginjava.net
> 
> 

-- 
View this message in context: http://www.nabble.com/Failing-to-read-messages%2C-AMQ5.0.0%2C-Stomp-tp19248190p19275913.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message