activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrico Teotti" <enrico.teo...@gmail.com>
Subject Re: stomp and message expiration
Date Wed, 06 Aug 2008 05:06:20 GMT
I've found the answer:
http://markmail.org/message/fvef2ur5dim6vjkx
"The expires property should be set to the time of expiration (in
millis) instead of the span to now. "

So in my tests I am going to add some milliseconds to
System.currentTimeMillis().
Cheers,
Enrico

2008/8/6 Enrico Teotti <enrico.teotti@gmail.com>:
> Hi,
> I am doing some tests with a standalone activemq broker and STOMP via telnet.
>
> I set up a producer and consumer and everything works fine. But when I send:
>
> SEND
> destination:/queue/FOO.BAR
> expires:20000
>
> expires in 20s
> ^@
>
> the consumer doesn't receive it, instead (checking with jconsole) the
> message goes in the DeadLetterQueue.
>
> When I (don't know why) tried:
>
> SEND
> destination:/queue/FOO.BAR
> expires:2000000000000
>
> it was a big surprise for me to see the message received by the consumer :-)
> Isn't the expires value in the producer's message header supposed to
> be in milliseconds?
>
> Thanks,
> Enrico
>
>
> --
> Enrico Teotti
> IT consultant, accessible web sites and web applications
> Sydney, NSW, Australia
> enrico.teotti@gmail.com
> mobile (IT) +393286590765
> mobile (AU) +00610416748450
>
> http://www.teotti.com
>



-- 
Enrico Teotti
IT consultant, accessible web sites and web applications
Sydney, NSW, Australia
enrico.teotti@gmail.com
mobile (IT) +393286590765
mobile (AU) +00610416748450

http://www.teotti.com

Mime
View raw message