activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ACKs not being delivered correctly in ActiveMQ 5.1 (QueueSize growing)
Date Wed, 13 Aug 2008 22:48:55 GMT
please use a PooledConnectionFactory - see http://activemq.apache.org/jmstemplate-gotchas.html

cheers,

Rob
On 13 Aug 2008, at 22:20, sateesh wrote:

>
> Hi,
>
>  We are using the active MQ Version 5.1.0 and our Java Client app uses
> Spring to Inject the jmsFactory and
>
>  Here is the part of spring config where we inject the jmsFactory..
>
> [CODE]
> <bean id="jmsFactory"  
> class="org.apache.activemq.ActiveMQConnectionFactory">
>    <property name="brokerURL">
>        <value>${jms.broker.url}</value>
>    </property>
>    </bean>
>    <bean id="messageProcessor"
>          class="com.app.MessageProcessorImplImpl"
>          init-method="init" >
>        <property name="jmsFactory">
>            <ref bean="jmsFactory" />
>        </property>
>    </bean>
> [/CODE]
>
> and MessageProcessorImpl overrides the onMessage() ...
>
> And by the way we switched back to ActiveMQ4.1 and everything works
> fine..The Spring version we are using is 2.0.6
>
> Sateesh
> -- 
> View this message in context: http://www.nabble.com/ACKs-not-being-delivered-correctly-in-ActiveMQ-5.1-%28QueueSize-growing%29-tp18944691p18971477.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message