activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Minh Tu Duong <m...@maas.de>
Subject Re: JMS-JMS bridge and wildcards
Date Fri, 08 Aug 2008 10:49:57 GMT
Hi all,

some body know that this bug already fixed? JMS bridge works correctly 
with wildcards.

cheers,
Minh Tu.

Travis Endersby schrieb:
> apache-activemq-5.1.0
>
> On Aug 1, 2008, at 1:46 AM, Rob Davies wrote:
>
>> that's an odd one - which version are you using?
>>
>> cheers,
>>
>> Rob
>>
>> On 31 Jul 2008, at 18:00, Travis Endersby wrote:
>>
>>> Hi Folks,
>>>
>>> I am looking to bridge many queues, such as "com.blah.foo" , 
>>> "com.blah.bar", "com.blah.nOtherThings"  between some jms servers.
>>>
>>>
>>> This is working great with the below type of set up, in that all 
>>> messages get accross ...Yet they lose their actual topic/queue name 
>>> and come in as the actual wildcard queue itself).
>>>
>>> ie;  how do I make sure that "com.blah.in.foo" comes across as 
>>> "com.blah.in.foo" instead of "com.blah.in.<"
>>>
>>> Thanks in advance
>>> Trav
>>>
>>>
>>>      <jmsBridgeConnectors>
>>>          <jmsQueueConnector 
>>> outboundQueueConnectionFactory="#remoteFactory">
>>>              <inboundQueueBridges>
>>>                  <inboundQueueBridge  
>>> inboundQueueName="com.blah.in.>" / >
>>>              </inboundQueueBridges>
>>>              <outboundQueueBridges>
>>>                  <outboundQueueBridge 
>>> outboundQueueName="com.blah.outbound.*" />
>>>              </outboundQueueBridges>
>>>          </jmsQueueConnector>
>>>      </jmsBridgeConnectors>
>>
>


Mime
View raw message