activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully" <gary.tu...@gmail.com>
Subject Re: How and Where to set asyncSend attribute ?
Date Wed, 27 Aug 2008 09:14:12 GMT
Hi Jill,
it is a client side option. An option that effects a message producer.
So you set it on the connection factory used by your client.
Either append "?jms.useAsyncSend=true" to the brokerUrl or in code,
invoke the ActiveMQConnectionFactory.setUseAsyncSend(boolean) method.


2008/8/27 Srini.Jill <srini.jil@gmail.com>:
>
> Hi Gary ,
>
> Thank You for the quick response.
>
> I have changed the property in
> src/main/resources/producer-conf/AMQ-Cons-5-1-queue.properties and could
> able to run the test .
>
> i could observe a increase in the through put of 100 with this option set .
>
> How can i set the option in a standalone server and a client program.
>
> Do i have to set on the connection factory that i create in the clinet
> program
>
> or
>
> Do i have to set on the  transport connector in the activemq.xml of the
> server like
>
>
> <transportConnectors>
>         <transportConnector name="openwire"
>                     uri="tcp://localhost:61616?jms.useAsyncSend=true"
>                     discoveryUri="multicast://default" />
>  </transportConnectors>
>
>
> Regards ,
> Jill
>
>
>
>
>
> Gary Tully wrote:
>>
>> Hi Jill,
>>
>> check out the readme.html
>> (https://svn.apache.org/repos/asf/activemq/trunk/activemq-perftest/readme.html)
>> in the activemq-perftest directory. It describes how to configure the
>> broker, consumer and producer portions of the test harness.
>>
>> You would be looking at something like:
>>   mvn activemq-perf:producer -Dfactory.useAsyncSend=true
>>
>> or modifying the value in the ConfigFile you choose, eg:
>> src/main/resources/producer-conf/AMQ-Cons-5-1-queue.properties
>>
>> Gary.
>>
>> 2008/8/26 Srini.Jill <srini.jil@gmail.com>:
>>>
>>> Hi ,
>>>
>>> I am doing the bench mark  testing for the Active MQ5.1 .
>>>
>>> I am using a standalone ActiveMQ server and consumer and producer clients
>>> from the Performance plugin of the activeMQ.
>>>
>>> While surfing the documentation , i figured out that setting the
>>> useAsyncSend=true will boost the performance .
>>>
>>> http://activemq.apache.org/connection-configuration-uri.html
>>>
>>> I have a couple of questions regarding the same.
>>>
>>> 1) How to set this property ?
>>>
>>> 2) Where to set this property ? if it is at the server side , where
>>> exactly
>>> in the activemq.xml
>>>
>>> I have tried by setting in the transportConnectors elements of the
>>> activemq.xml.
>>>
>>> <transportConnectors>
>>>         <transportConnector name="openwire"
>>> uri="tcp://localhost:61616?jms.useAsyncSend=true"
>>> discoveryUri="multicast://default" />
>>> </transportConnectors>
>>>
>>> and in the client side ,
>>>
>>>  mvn activemq-perf:consumer
>>> -Durl=broker:tcp://localhost:61616?jms.useAsyncSend=true
>>> -DsysTest.propsConfigFile=src/main/resources/consumer-conf/AMQ-Cons-5-1-queue.properties
>>>
>>>  mvn activemq-perf:producer
>>> -Durl=broker:tcp://localhost:61616?jms.useAsyncSend=true
>>> -DsysTest.propsConfigFile=src/main/resources/producer-conf/AMQ-Cons-5-1-queue.properties
>>>
>>> I could able to generate the report but in the reports i could see
>>> useAsyncSen=false and the through put is also very low.
>>>
>>> Please let me know , how to test the performance with useAsyncSen=true on
>>> a
>>> standalone installation .
>>>
>>> Regards,
>>> Jill
>>> --
>>> View this message in context:
>>> http://www.nabble.com/How-and-Where-to-set-asyncSend-attribute---tp19160219p19160219.html
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>
>>>
>>
>>
>
> --
> View this message in context: http://www.nabble.com/How-and-Where-to-set-asyncSend-attribute---tp19160219p19174823.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message