activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bopfermann <bopferm...@entertainment.com>
Subject 20ish second delay after MDB Redeploy on JBoss
Date Tue, 05 Aug 2008 15:54:35 GMT

I have a simple MDB deployed in JBoss which listens on a queue on a remote
broker.  On a clean start of both activemq (5.1.0) and JBoss (4.2.1.GA), the
interaction works well and fast.  I can load it with over 1500 messages and
it consumes them quite fast.  The problem occurs when I redeploy the MDB
jar.  At that point, messages can be added to the queue, but take
approximately 20 seconds to become consumed by the MDB.  On the admin screen
I can see the message(s) in a pending state for those 20 seconds.  They DO
EVENTUALLY DELIVER, but it appears as if it is waiting for a timeout on some
old connection.  Restarting either activemq or jboss alone does not remedy
the situation, it requires a restart of both simultaneously.

I have tried various rar configurations as well as activiationconfigs, but
can't seem to gain anything.  My current setup basics to follow....

MDB Config
@MessageDriven(activationConfig = { @ActivationConfigProperty(propertyName =
"destinationType", propertyValue = "javax.jms.Queue"),
		@ActivationConfigProperty(propertyName = "clientId", propertyValue =
"SOARouter"),
		@ActivationConfigProperty(propertyName = "destination", propertyValue =
"activemq/queue/SOAInQueue"),
		@ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue
= "Auto-acknowledge") })
@ResourceAdapter("activemq-rar-5.1.0.rar")

rar's ServerUrl: tcp://remoteHost:61616

jms-ds.xml relative pieces
<tx-connection-factory>
      <jndi-name>activemq/QueueConnectionFactory</jndi-name>
      <xa-transaction/>
      <track-connection-by-tx/> <!-- Thanks to Adrian Brock for pointing
this one out! -->
      <rar-name>activemq-rar-5.1.0.rar</rar-name>
     
<connection-definition>javax.jms.QueueConnectionFactory</connection-definition>
     
<security-domain-and-application>JmsXARealm</security-domain-and-application>
   </tx-connection-factory>
<mbean code="org.jboss.resource.deployment.AdminObject"
name="activemq.queue:name=SOAInQueue">
      <attribute name="JNDIName">activemq/queue/SOAInQueue</attribute>
      <depends
optional-attribute-name="RARName">jboss.jca:service=RARDeployment,name='activemq-rar-5.1.0.rar'</depends>
      <attribute name="Type">javax.jms.Queue</attribute>
      <attribute name="Properties">
            PhysicalName=activemq/queue/SOAInQueue
      </attribute>
   </mbean>

Any guidance would be appreciated.
-- 
View this message in context: http://www.nabble.com/20ish-second-delay-after-MDB-Redeploy-on-JBoss-tp18834110p18834110.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message