activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bopfermann <>
Subject 20ish second delay after MDB Redeploy on JBoss
Date Tue, 05 Aug 2008 15:54:35 GMT

I have a simple MDB deployed in JBoss which listens on a queue on a remote
broker.  On a clean start of both activemq (5.1.0) and JBoss (4.2.1.GA), the
interaction works well and fast.  I can load it with over 1500 messages and
it consumes them quite fast.  The problem occurs when I redeploy the MDB
jar.  At that point, messages can be added to the queue, but take
approximately 20 seconds to become consumed by the MDB.  On the admin screen
I can see the message(s) in a pending state for those 20 seconds.  They DO
EVENTUALLY DELIVER, but it appears as if it is waiting for a timeout on some
old connection.  Restarting either activemq or jboss alone does not remedy
the situation, it requires a restart of both simultaneously.

I have tried various rar configurations as well as activiationconfigs, but
can't seem to gain anything.  My current setup basics to follow....

MDB Config
@MessageDriven(activationConfig = { @ActivationConfigProperty(propertyName =
"destinationType", propertyValue = "javax.jms.Queue"),
		@ActivationConfigProperty(propertyName = "clientId", propertyValue =
		@ActivationConfigProperty(propertyName = "destination", propertyValue =
		@ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue
= "Auto-acknowledge") })

rar's ServerUrl: tcp://remoteHost:61616

jms-ds.xml relative pieces
      <track-connection-by-tx/> <!-- Thanks to Adrian Brock for pointing
this one out! -->
<mbean code="org.jboss.resource.deployment.AdminObject"
      <attribute name="JNDIName">activemq/queue/SOAInQueue</attribute>
      <attribute name="Type">javax.jms.Queue</attribute>
      <attribute name="Properties">

Any guidance would be appreciated.
View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message