activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject RE: Build Problem ActiveMQ-CPP 2.2
Date Thu, 28 Aug 2008 13:13:33 GMT
Our sample project expects all of them to be in an APR folder under
Program Files, if yours is different then you need to add all the
difference to the additional libraries and additional include
directories of the sample project.

On Thu, 2008-08-28 at 09:06 -0400, Powers, Matthew wrote:
> I have them in 3 directores C:\Program Files\APR, C:\Program
> Files\APR-ICONV, and C:\Program Files\APR-util I believe that is the
> correct setup. 
> 
> -----Original Message-----
> From: Timothy Bish [mailto:tabish121@gmail.com] 
> Sent: Wednesday, August 27, 2008 5:31 PM
> To: users@activemq.apache.org
> Subject: Re: Build Problem ActiveMQ-CPP 2.2
> 
> Definitely sounds like its not able to find the lib file which means its
> probably not setup correctly.  By default we expect in our projects file
> that the APR stuff is installed under C:\Program Files\APR if you have
> them somewhere else then you need to carefully add that location into
> all the include and link directory settings in Visual Studio.  The best
> bet to get going quickly is to follow the build instructions in APR and
> use nmake to build it and install it in the expected place:
> 
> nmake -f Makefile.win PREFIX=c:\Program Files\APR
> 
> Regards
> Tim.
> 
> On Wed, 2008-08-27 at 16:54 -0400, Powers, Matthew wrote:
> > Has anyone run into a problem when they try to build through the
> > activemq-cpp-2.2\vs2005-build\vs2005-activemq-cpp.sln 
> > 
> > Similar to this:
> > 
> > Error     19         fatal error LNK1104: cannot open file
> > 'libapr-1.lib'   vs2005-activemq-unittests           
> > 
> > I am trying to build activemq-cpp and I keep getting this error.  I am
> > able to build the vs2005-activemq project but not the example and it
> is
> > driving me crazy.
> > 
> > As far as I can see that file should be in the apr\debug folder, and I
> > set it up in the project path. 
> > 
> > Am I missing something?
> > 
> > Thanks for the information.
> > 
> >  
> > 
> > 
> > 
> > Matt Powers
> > 
> > Sr. Software Research Engineer
> > 
> > Textron Defense Systems
> > 
> > Advanced Solutions Center
> > 
> > 201 Lowell Street
> > 
> > Wilmington, MA 01887
> > 
> > Phone: (978) 657-2490
> > 
> > Fax:     (978) 657-1201
> > 
> >  
> > 
> 


Mime
View raw message