activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: Master/Slave Configuration with Network of Brokers working fine But In Master console it shows errors
Date Mon, 07 Jul 2008 15:41:56 GMT
On Mon, Jul 7, 2008 at 9:10 AM, Manish1985 <pramanish@gmail.com> wrote:
>
> Hi All,
>
> I have configured Master and Slaves with Network of Brokers. Here All
> messages are received and sent properly but in Master ActiveMQ server i get
> following errors while sending each message.
>
> 2008-03-07 19:30:41,125 [/127.0.0.1:1638] ERROR MasterBroker
> - Slave Failed
> java.lang.AssertionError: Unsupported Method
>        at
> org.apache.activemq.transport.TransportSupport.request(TransportSupport.java:71)
>        at
> org.apache.activemq.transport.TransportFilter.request(TransportFilter.java:88)
>        at
> org.apache.activemq.transport.TransportFilter.request(TransportFilter.java:88)
>        at
> org.apache.activemq.transport.MutexTransport.request(MutexTransport.java:49)
>        at
> org.apache.activemq.broker.ft.MasterBroker.sendSyncToSlave(MasterBroker.java:363)
>        at
> org.apache.activemq.broker.ft.MasterBroker.sendToSlave(MasterBroker.java:345)
>        at
> org.apache.activemq.broker.ft.MasterBroker.acknowledge(MasterBroker.java:320)
>        at
> org.apache.activemq.broker.MutableBrokerFilter.acknowledge(MutableBrokerFilter.java:88)
>        at
> org.apache.activemq.broker.TransportConnection.processMessageAck(TransportConnection.java:488)
>        at org.apache.activemq.command.MessageAck.visit(MessageAck.java:179)
>        at
> org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:284)
>        at
> org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:177)
>        at
> org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:65)
>        at
> org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:133)
>        at
> org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:122)
>        at
> org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
>        at
> org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:137)
>        at java.lang.Thread.run(Thread.java:595)
>
> Can anybody give me solution of this error i tried with activeMQ5.0 but it
> rather than solving my problem makes the problem more worse.
>
> Can anybody help in this regards, Your help will be appreciated.

Have you tried using the latest release of ActiveMQ 5.1?:

http://activemq.apache.org/activemq-510-release.html

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache Camel - http://activemq.org/camel/
Apache ServiceMix - http://servicemix.org/

Blog: http://bruceblog.org/

Mime
View raw message