activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully" <gary.tu...@gmail.com>
Subject Re: Spring configuration problem (without XBean)
Date Thu, 31 Jul 2008 15:41:08 GMT
with  <property name="ignoreUnresolvablePlaceholders" value="true" />
are you sure it can find classpath:activemq.properties?


2008/7/31 BlueFox <bluefoxreg@gmail.com>:
>
> I'm trying to configure my activemq embedded broker without spring but I
> can't seem to get it to work, can someone tell me what I did wrong in the
> configuration?
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://www.springframework.org/schema/beans"
> xmlns:amq="http://activemq.apache.org/schema/core"
>        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>        xsi:schemaLocation="http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
>        http://activemq.apache.org/schema/core
> http://activemq.apache.org/schema/core/activemq-core-5.1.0.xsd">
>
>        <bean
>
> class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
>                <property name="locations"
>                        value="classpath:activemq.properties" />
>                <!-- !!!Note: Any System properties set will be used instead of the
value
> set in the properties file -->
>                <property name="systemPropertiesMode" value="2" />
>                <property name="ignoreUnresolvablePlaceholders" value="true" />
>        </bean>
>
>        <!-- Embedded ActiveMQ Broker -->
>        <amq:broker brokerName="localhost" useJmx="${activemq.useJmx}"
>                persistent="true">
>                <amq:transportConnectors>
>                        <amq:transportConnector uri="${activemq.broker}" />
>                </amq:transportConnectors>
>                <amq:persistenceAdapter>
>                        <amq:amqPersistenceAdapter directory="${activemq.data}"/>
>                </amq:persistenceAdapter>
>        </amq:broker>
>
>        <!-- ActiveMQ destinations to use for Upstream -->
>        <amq:queue id="test"  physicalName="test.queue"/>
>
>        <!-- JMS ConnectionFactory to use, configuring the embedded broker using
> XML -->
>        <amq:connectionFactory id="amqConnectionFactory"
> brokerURL="vm://localhost"/>
>
>        <!-- Pooled connection factory -->
>        <bean id="jmsFactory"
> class="org.apache.activemq.pool.PooledConnectionFactory"
>                init-method="start" destroy-method="stop">
>                <property name="connectionFactory" ref="amqConnectionFactory" />
>        </bean>
> </beans>
>
> When I start my program, I get this error:
> Line 20 in XML document from class path resource [activemq.config.xml] is
> invalid; nested exception is org.xml.sax.SAXParseException:
> cvc-datatype-valid.1.2.1: '${activemq.useJmx}' is not a valid value for
> 'boolean'.
>
> The program works if I replace all the ${variable} with the actual value,
> but I'm not sure why this does not work as intended, can anyone enlighten me
> please?
> --
> View this message in context: http://www.nabble.com/Spring-configuration-problem-%28without-XBean%29-tp18756668p18756668.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message