activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From new2mq <chris.gooda...@sungard.com>
Subject Re: Problems with simple peer:// transport config & Spring
Date Thu, 31 Jul 2008 17:18:01 GMT

A couple of things that were not included in the original post:

1) We are using Spring 2.0, not 2.5
2) The code posted is obviously from a simple test app, and not our real
usage.
3)  I have attached the entire test (testamq.jar), which includes:
     build.xml - use targets "run" to run only as a listener, "runSender" to
run as a sender-listener
     test-amq-peer.jar - this is automatically built by both the run and
runSender targets, but included it anyway 
    activemq-core-4.1.1.jar, j2ee.jar, spring.jar,  commons-logging.jar,
backport-util-concurrent-2.1.jar,  activeio-core-3.0-incubator.jar -
Dependent jars
    spring-config.xml - The Spring configuration file for the tests
    /src/**.java - The 4 java source files in this test (only 3 required).

To replicate - explode testamq.jar on two different machines in the same
segment.   run:  ant run on one machine and ant runSender on the other.  
You should see the runSender instance both sending and receiving messages.  
The "run" instance never gets the messages.   If you run both on the same
machine, both instances receive the messages.

-chris http://www.nabble.com/file/p18759336/testamq.jar testamq.jar 




new2mq wrote:
> 
> I understand that.   Both machines are on the same segment:
> 
> Machine A:  10.15.2.62
> Machine B:  10.15.2.105
> 
> {... remainder of thread snipped ... }
> 

-- 
View this message in context: http://www.nabble.com/Problems-with-simple-peer%3A---transport-config---Spring-tp18755772p18759336.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message