activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Fernandez <joe.fernan...@ttmsolutions.com>
Subject Re: Network of Brokers, Temp Queue problem
Date Sun, 20 Jul 2008 21:11:32 GMT

I typically see the "Cannot publish to a deleted Destination" exception
hurled when the producing broker does not have a forwarding bridge back to
the consuming broker (i.e., broker w/the temp queue). Do you have
transportConnectors set up for both brokers? 

Use caution when setting wireFormat.maxInactivityDuration to 0 in
combination with the failover connector. With this combination, there are
cases when your 'consumer' clients will hang if they lose their network
connection to their broker. 

Joe
www.ttmsolutions.com 



rpratt wrote:
> 
> I have seen several other posts that are somewhat like my problem, but
> none directly address my issue...hopefully someone can help me out here.
> 
> I have configured two brokers on separate machines as a network of
> brokers. The connectors between them is:
> 
> networkConnectors>
>             <networkConnector name="${connector.name}" networkTTL="2"
> dynamicOnly="true" uri="${connector.uri}" conduitSubscriptions="false"/>
> </networkConnectors>
> 
> 
> the connector.uri value is static://(tcp://host2:61616) on host1 and
> static://(tcp://host1:61616) on host2
> 
> the name is devconnector for both.
> 
> I have several producers and consumers connected with the uri
> failover:(tcp://host1:61616?wireFormat.maxInactivityDuration=0,tcp://host2:61616?wireFormat.maxInactivityDuration=0)?jms.useAsyncSend=true&jms.prefetchPolicy.all=1
> 
> 
> I have a service listening on known queue name (actually the service has
> 10 threads each receiving on that queue name). When a service thread
> receives a message it produces a result and sends it back to the replyTo
> destination set on the incoming message. The replyTo destination is a
> temporary queue set up by the sender. I often get the following error when
> the service is trying to send the reply:
> 
> javax.jms.InvalidDestinationException: Cannot publish to a deleted
> Destination: temp-queue://ID:oslchi6ddev13-53619-1216502331985-0:6081:1
> 
> 
> If I shut down one of the brokers this error goes away, so it seems like
> it has something to do with the network of brokers.
> 
> Is this a known issue? If so is there a workaround? Or am I just doing
> something that is not supposed to work with a network of brokers?  Thanks
> 
> Ryan P
> 

-- 
View this message in context: http://www.nabble.com/Network-of-Brokers%2C-Temp-Queue-problem-tp18549419p18558830.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message