activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From subrash <subr...@yahoo.com>
Subject Re: unable to compile activemq-cpp on redhat linux 4.0 with gcc 3.4
Date Wed, 16 Jul 2008 15:50:54 GMT

Thanks for the info . First i was  able to get the active-mq-cpp to compile
on ubuntu with no issues unfortunately i am still stuck on linux_redhat EL 4 
( our production problem) . In your comment i see something about copying
the cppunit file . what file do you copy where ? First i modified
configure.ac to comment out the -fstrict-aliasing and w-Strict-aliasing=2
and then it started compiling but however it is now stuck at 


"g++ -DHAVE_CONFIG_H -I. -I. -I../.. -ansi -pedantic -DLINUX=2 -D_REENTRANT
-D_GNU_SOURCE -I/usr/local/apr/include/apr-0 -I/usr/local/apr/include/apr-0
-W -Wall -fPIC -Wno-long-long -g -O2 -MT
activemq/exceptions/libactivemq_cpp_la-ActiveMQException.lo -MD -MP -MF
activemq/exceptions/.deps/libactivemq_cpp_la-ActiveMQException.Tpo -c
activemq/exceptions/ActiveMQException.cpp  -fPIC -DPIC -o
activemq/exceptions/.libs/libactivemq_cpp_la-ActiveMQException.o
activemq/exceptions/ActiveMQException.h:35: sorry, not implemented:
adjusting 
   pointers for covariant returns
activemq/exceptions/ActiveMQException.h:35: sorry, not implemented:
adjusting 
   pointers for covariant returns
make[2]: *** [activemq/exceptions/libactivemq_cpp_la-ActiveMQException.lo]
Error 1
make[2]: Leaving directory `/home/software/activemq-cpp-2.2/src/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/software/activemq-cpp-2.2'
make: *** [all] Error 2"

Any Help will be greatly appreciated 






sfred wrote:
> 
> I had similar problems for weeks until I finally ignored the build
> instructions on the ActiveMQ-CPP site and simply built with the default
> redhat 4 (update 4) autotools: libtool, autoconf, automake (rather than
> upgrading to the versions they recommended).  The one key piece of
> information that helped me was to copy the cppunit.m4 into the
> activemq-cpp/m4 directory because the build scripts couldn't find my
> non-standard cppunit install location.  The other strange thing that
> happened to me was that the tar.gz file that I downloaded had bogus
> filenames that had to be fixed - specifically, there were 20 - 30 files
> renamed from *.cpp to *.cpp0000664 and *.h to *.h0000664.  Do a find .
> -name '*.00664' to see if you get the same problem.  I'm not sure where
> that piece got messed up, but once I got those few things worked out, I
> was able to build it without too much trouble.
> 
> If you want more help.  Tell me specifically where the build process is
> failing for you.
> 
> Scott
> 
> 
> subrash wrote:
>> 
>> i have been trying for a while to compile activemq-cpp on redhat linux
>> 4.0. if anybody can point me to an rpm or a binary load for the ame i
>> will be grateful.  i tried to download active-mq from the site and it did
>> not compile even when i diabled some of the warnings. even downloading
>> from the fue site did not help. 
>> i will post the error mesages on monday. but if any one has access to a
>> binary or rpm it will be greatly appreciated.
>> thx
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/unable-to-compile-activemq-cpp-on-redhat-linux-4.0-with-gcc-3.4-tp15925879p18490578.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message