activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From toli <t...@marketcetera.com>
Subject Re: NMS doesn't work with latest ActiveMQ
Date Thu, 10 Jul 2008 23:47:51 GMT

Jim, 

Thanks a lot for the clariification. I got my integration code to work using
the latest code from SVN trunk, i can speak with the 5.1 ActiveMQ. Most of
my problems ended up being "user errors", but i was a little hesitant to
rely on something with failing unit tests.

I've tested my integration points and everything seems to work for me.

Thanks for your help, and looking forward to the stable release.



semog wrote:
> 
> The NMS code should be working, but I do know that all of the unit tests
> currently do not pass.  I have scheduled your JIRA report (thanks!) as a
> working item to get all of the unit tests to pass before shipping NMS 1.0.
> 
> I have not tested running NMS against 4.1, but I would expect it to work.
> The latest NMS should work against 5.0, 5.1 and 5.2.  Please post any
> specific issues you are having, whether it is initial connectivity or
> getting messages to flow.
> 
> Thanks,
> Jim
> 
> On Thu, Jul 3, 2008 at 8:13 AM, toli <toli@marketcetera.com> wrote:
> 
>>
>> Can someone tell me which version of ActiveMQ the latest NMS code is
>> supposed
>> to work with?
>>
>> We've used NMS code from about a year ago with nms-activemq subproject to
>> build our .NET integration and that worked with ActiveMQ 4.1
>>
>> I"ve recently decided to upgrade to the newer versions of NMS and
>> NMS.ActiveMQ adapters. It doesn't look like either one is available as a
>> binary download, so i tried building it from source from SVN head.
>>
>> When i run unit tests (btw, there's no 'nant test' target in the nant
>> files)
>> from Visual Studio i'm getting
>> quite a few errors in the basic NMS and NMS.ActiveMQ tests.
>>
>> I'm running them against the embedded 5.1 ActiveMQ message broker that we
>> are shipping with. The NMS code we built that worked with ActiveMQ 4.1 no
>> longer works with ActiveMQ 5.1, and the unit tests in NMS are failing
>> against 5.1 as well.
>>
>> The new NMS code doesn't run against 4.1 either.
>>
>> I've posted the details to JIRA and developer forum, but haven't heard
>> anything yet:
>>
>> JIRA:  https://issues.apache.org/activemq/browse/AMQNET-92
>> Nabble:
>>
>> http://www.nabble.com/Running-unit-tests-in-NMS-against-ActiveMQ-results-in-errors-tp18162028p18162028.html
>>
>> thanks
>> --
>> View this message in context:
>> http://www.nabble.com/NMS-doesn%27t-work-with-latest-ActiveMQ-tp18260197p18260197.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/NMS-doesn%27t-work-with-latest-ActiveMQ-tp18260197p18394205.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message