activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Demian Mrakovich <nede...@hotmail.com>
Subject Re: No clientID specified for connection disconnect request
Date Thu, 10 Jul 2008 15:47:32 GMT

Thanks for the bump and for the work-around!

But - turning off async dispatch reduces performance with slow consumers if
I understand correctly, so I would prefer having it on. Is there a "better"
solution to this? Is it a bug or do I have bad config somewhere?



rajdavies wrote:
> 
> Great! thx Benoitx!
> 
> On 9 Jul 2008, at 16:31, Benoitx wrote:
> 
>>
>> let me answer my own question... the config is in an xml file...
>> this works:
>> vm://localhost?create=false&amp;async=false
>>
>> We'll get back to the list if it re-occurs but... it seems to have  
>> fixed the
>> clientID issue.
>>
>> Thanks!!!
>>
>> Benoit
>>
>>
>> Benoitx wrote:
>>>
>>> Thanks a lot for this.
>>>
>>> Could you confirm the syntax to add more than one parameter?
>>>
>>> We already have: vm://localhost?create=false
>>>
>>> so I tried vm://localhost?create=false&async=false  but this is
>>> rejected...
>>>
>>> Sorry, it is a very basic question...
>>>
>>> Benoit
>>>
>>>
>>> rajdavies wrote:
>>>>
>>>> work around could be to  turn async dispatch off in the vm://
>>>> transport - e.g. vm://localhost?async=false
>>>>
>>>> On 8 Jul 2008, at 23:42, Benoitx wrote:
>>>>
>>>>>
>>>>> Same here.
>>>>>
>>>>> This error seems to happen on the FIRST message sent by thread in
>>>>> JBoss...
>>>>> After the first message, it seems to go away...  Quite annoying.
>>>>>
>>>>> Any suggestion ? Solution? workaround?
>>>>>
>>>>> Thanks
>>>>>
>>>>> Benoit
>>>>>
>>>>>
>>>>>
>>>>> Demian Mrakovich wrote:
>>>>>>
>>>>>> Just upgraded from 4.1 to 5.1 and get this exception now right
>>>>>> after every
>>>>>> message is received. Messages get processed fine anyway, but the
>>>>>> stacktrace really litters the log and maybe it is a symptom of an
>>>>>> error of
>>>>>> some kind. Googled this message, but to no avail... Any  
>>>>>> suggestions
>>>>>> on how
>>>>>> to get rid of it?
>>>>>>
>>>>>> 2008-06-19 14:01:52,586 WARN
>>>>>> [org.apache.activemq.broker.TransportConnection.Service] Failed to
>>>>>> remove
>>>>>> connection ConnectionInfo {commandId = 1, responseRequired = true,
>>>>>> conn
>>>>>> ectionId = ID:ubuntu.linpro.no-53402-1213876871547-2:11,  
>>>>>> clientId =
>>>>>> null,
>>>>>> userName = defaultUser, password = defaultPassword, brokerPath =
>>>>>> null,
>>>>>> brokerMasterConnector = false,
>>>>>> manageable = true, clientMaster = true}
>>>>>> javax.jms.InvalidClientIDException: No clientID specified for
>>>>>> connection
>>>>>> disconnect request
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .broker.region.RegionBroker.removeConnection(RegionBroker.java: 
>>>>>> 225)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .broker.TransactionBroker.removeConnection(TransactionBroker.java:
>>>>>> 248)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .advisory.AdvisoryBroker.removeConnection(AdvisoryBroker.java:214)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq.broker.BrokerFilter.removeConnection(BrokerFilter.java:

>>>>>> 109)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .broker
>>>>>> .MutableBrokerFilter.removeConnection(MutableBrokerFilter.java: 
>>>>>> 116)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .broker
>>>>>> .TransportConnection
>>>>>> .processRemoveConnection(TransportConnection.java:704)
>>>>>>       at
>>>>>> org.apache.activemq.command.RemoveInfo.visit(RemoveInfo.java:60)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .broker.TransportConnection.service(TransportConnection.java:292)
>>>>>>       at
>>>>>> org.apache.activemq.broker.TransportConnection
>>>>>> $1.onCommand(TransportConnection.java:180)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq
>>>>>> .transport.ResponseCorrelator.onCommand(ResponseCorrelator.java:

>>>>>> 104)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq 
>>>>>> .transport.TransportFilter.onCommand(TransportFilter.java:
>>>>>> 68)
>>>>>>       at
>>>>>> org
>>>>>> .apache 
>>>>>> .activemq.transport.vm.VMTransport.iterate(VMTransport.java:
>>>>>> 205)
>>>>>>       at
>>>>>> org
>>>>>> .apache
>>>>>> .activemq.thread.PooledTaskRunner.runTask(PooledTaskRunner.java:

>>>>>> 122)
>>>>>>       at
>>>>>> org.apache.activemq.thread.PooledTaskRunner
>>>>>> $1.run(PooledTaskRunner.java:43)
>>>>>>       at
>>>>>> java.util.concurrent.ThreadPoolExecutor
>>>>>> $Worker.runTask(ThreadPoolExecutor.java:650)
>>>>>>       at
>>>>>> java.util.concurrent.ThreadPoolExecutor
>>>>>> $Worker.run(ThreadPoolExecutor.java:675)
>>>>>>       at java.lang.Thread.run(Thread.java:595)
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> -----
>>>>> Thanks & Regards,
>>>>>
>>>>> Benoit
>>>>>
>>>>> http://www.Appendium.com   http://objectlab.blogspot.com
>>>>>
>>>>> -- 
>>>>> View this message in context:
>>>>> http://www.nabble.com/No-clientID-specified-for-connection-disconnect-request-tp18008702p18350696.html
>>>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>> -----
>> Thanks & Regards,
>>
>> Benoit
>>
>> http://www.Appendium.com   http://objectlab.blogspot.com
>>
>> -- 
>> View this message in context:
>> http://www.nabble.com/No-clientID-specified-for-connection-disconnect-request-tp18008702p18363293.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/No-clientID-specified-for-connection-disconnect-request-tp18008702p18385571.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message