activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joselu <jose_luis.lopez_d...@alcatel-lucent.es>
Subject RE: Openwire C client protocol error
Date Thu, 10 Jul 2008 10:10:46 GMT

Thanks, Nate
Yes, we're using a C++ compiler. Openwire C client was one of the
alternatives. The other one is CPP but  we were a bit afraid about the
integration of CPP API code (threading and so)  with our event loop. So, we
have tried the other one as first choice. Now, we'll have a look to CPP.

Regards,
Joselu 



Mittler, Nathan wrote:
> 
> Just curious ... are you building with a C++ compiler?  If so, you might
> want to think about just using ActiveMQ-CPP:
> http://activemq.apache.org/cms/
> 
> I'm not sure if the Openwire C client is being maintained.
> 
> Regards,
> Nate
> 
>> -----Original Message-----
>> From: Joselu [mailto:jose_luis.lopez_diaz@alcatel-lucent.es]
>> Sent: Wednesday, July 09, 2008 2:32 AM
>> To: users@activemq.apache.org
>> Subject: Openwire C client protocol error
>> 
>> 
>> Hi,
>> we want to integrate our linux C application with ActiveMQ broker 5.1.0
>> using Openwire C Client. As a first step, we are trying to make the
>> example
>> works but we have a problem in the fist step of the protocol, during the
>> wire format negociation. It seems that the message is not well formatted
>> in
>> client side.
>> The client example and broker run in the same linux machine.
>> I attach dump of the trace at broker side.
>> So, we wonder if the example taken from web runs OK or there is any known
>> issue. We have also checked it with AMQ broker 4.1.2 unsuccessfully.
>> 
>> Anyone has been succesful in this stuff? Any ideas about this problem?
>> 
>> Thanks in advance
>> Joselu
>> 
> 

-- 
View this message in context: http://www.nabble.com/Openwire-C-client-protocol-error-tp18357667p18379729.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message