activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From toli <t...@marketcetera.com>
Subject NMS doesn't work with latest ActiveMQ
Date Thu, 03 Jul 2008 15:13:05 GMT

Can someone tell me which version of ActiveMQ the latest NMS code is supposed
to work with?

We've used NMS code from about a year ago with nms-activemq subproject to
build our .NET integration and that worked with ActiveMQ 4.1

I"ve recently decided to upgrade to the newer versions of NMS and
NMS.ActiveMQ adapters. It doesn't look like either one is available as a
binary download, so i tried building it from source from SVN head.

When i run unit tests (btw, there's no 'nant test' target in the nant files)
from Visual Studio i'm getting
quite a few errors in the basic NMS and NMS.ActiveMQ tests.

I'm running them against the embedded 5.1 ActiveMQ message broker that we
are shipping with. The NMS code we built that worked with ActiveMQ 4.1 no
longer works with ActiveMQ 5.1, and the unit tests in NMS are failing
against 5.1 as well.

The new NMS code doesn't run against 4.1 either. 

I've posted the details to JIRA and developer forum, but haven't heard
anything yet:

JIRA:  https://issues.apache.org/activemq/browse/AMQNET-92
Nabble: 
http://www.nabble.com/Running-unit-tests-in-NMS-against-ActiveMQ-results-in-errors-tp18162028p18162028.html

thanks
-- 
View this message in context: http://www.nabble.com/NMS-doesn%27t-work-with-latest-ActiveMQ-tp18260197p18260197.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message