activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas Mervaillie" <nmervail...@gmail.com>
Subject Problems running master/slave configuration
Date Wed, 18 Jun 2008 17:41:56 GMT
Hi,

I have issues running a master/slave configuration (brokers configuration
attached).
Here is what I do :
 - Start master
 - Start slave
 - Shutdown slave
 - Restart slave

=> Messages are not transmitted anymore.
=> Master displays :
javax.jms.JMSException: The destination topic://ActiveMQ.Advisory.Connection
does not exist.
        at
org.apache.activemq.broker.region.AbstractRegion.lookup(AbstractRegion.java:395)
        at
org.apache.activemq.broker.region.AbstractRegion.send(AbstractRegion.java:341)
        at
org.apache.activemq.broker.region.RegionBroker.send(RegionBroker.java:445)
        at
org.apache.activemq.broker.TransactionBroker.send(TransactionBroker.java:224)
        at
org.apache.activemq.advisory.AdvisoryBroker.fireAdvisory(AdvisoryBroker.java:325)
        at
org.apache.activemq.advisory.AdvisoryBroker.fireAdvisory(AdvisoryBroker.java:268)
        at
org.apache.activemq.advisory.AdvisoryBroker.fireAdvisory(AdvisoryBroker.java:260)
        at
org.apache.activemq.advisory.AdvisoryBroker.addConnection(AdvisoryBroker.java:78)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:81)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:88)
        at
org.apache.activemq.broker.TransportConnection.processAddConnection(TransportConnection.java:662)
        at
org.apache.activemq.command.ConnectionInfo.visit(ConnectionInfo.java:125)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:292)
        at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:180)
        at
org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:143)
        at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:206)
        at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
        at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:196)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:183)
        at java.lang.Thread.run(Thread.java:595)

I don't get what's going wrong.
Can someone help me on this ?

Thanks

Nicolas

PS : On master shutdown, using failover urls, messages are routed to the
slave and dispatched properly

Mime
View raw message